summaryrefslogtreecommitdiff
path: root/sysdeps/mach/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>2002-04-02 04:43:06 +0000
committerRoland McGrath <roland@gnu.org>2002-04-02 04:43:06 +0000
commitdb6b51ada724d76d2d8a4b80dfbc20235fcdb0e7 (patch)
tree9e2e39ac4a7cce6940f61c195ccdd26dc4895ae0 /sysdeps/mach/configure.in
parent96c4df505528ff3a5ca8f9377481bc928be547de (diff)
* hurd/hurdselect.c (_hurd_select): Fix
MACH_MSG_TYPE_INTEGER_T -> integer_t in sizeof. Use a union rather than casts to compare mach_msg_type_t as int. 2002-03-25 Roland McGrath <roland@frob.com> * hurd/hurdchdir.c (_hurd_change_directory_port_from_name): Don't check off the end of NAME when it's shorter than 2 chars. Reported by Ognyan Kulev <ogi@fmi.uni-sofia.bg>. 2002-03-17 Roland McGrath <roland@frob.com> * sysdeps/mach/hurd/i386/sys/io.h: New file. * sysdeps/mach/hurd/i386/ioperm.c: New file. * sysdeps/mach/hurd/i386/Dist: Add them. * sysdeps/mach/hurd/i386/Versions (libc: GLIBC_2.2.6): New set, add ioperm. * sysdeps/mach/configure.in: New check to set HAVE_I386_IO_PERM_MODIFY. (mach_interface_list): Check for mach_i386.defs. * config.h.in (HAVE_I386_IO_PERM_MODIFY): #undef it. * sysdeps/mach/configure: Regenerated.
Diffstat (limited to 'sysdeps/mach/configure.in')
-rw-r--r--sysdeps/mach/configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/sysdeps/mach/configure.in b/sysdeps/mach/configure.in
index 541fd77e59..fca2063e65 100644
--- a/sysdeps/mach/configure.in
+++ b/sysdeps/mach/configure.in
@@ -52,6 +52,7 @@ for ifc in mach mach4 \
clock clock_priv host_priv host_security ledger lock_set \
processor processor_set task thread_act vm_map \
memory_object memory_object_default default_pager \
+ i386/mach_i386 \
; do
AC_CHECK_HEADER(mach/${ifc}.defs, [dnl
mach_interface_list="$mach_interface_list $ifc"])
@@ -73,3 +74,12 @@ AC_CHECK_HEADER(mach/machine/ndr_def.h, [dnl
DEFINES="$DEFINES -DNDR_DEF_HEADER='<mach/machine/ndr_def.h>'"], [dnl
AC_CHECK_HEADER(machine/ndr_def.h, [dnl
DEFINES="$DEFINES -DNDR_DEF_HEADER='<machine/ndr_def.h>'"])])
+
+AC_CACHE_CHECK(for i386_io_perm_modify in mach_i386.defs,
+ libc_cv_mach_i386_ioports, [dnl
+AC_EGREP_HEADER(i386_io_perm_modify, mach/i386/mach_i386.defs,
+ libc_cv_mach_i386_ioports=yes,
+ libc_cv_mach_i386_ioports=no)])
+if test $libc_cv_mach_i386_ioports = yes; then
+ AC_DEFINE([HAVE_I386_IO_PERM_MODIFY])
+fi