summaryrefslogtreecommitdiff
path: root/sysdeps/mach/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>2002-10-18 01:49:07 +0000
committerRoland McGrath <roland@gnu.org>2002-10-18 01:49:07 +0000
commit2d37ce0f616d7b17d4bb39744af5ec43d35a9dbd (patch)
tree5e36f2ee090b76df229daaac6802e2c19274ff1c /sysdeps/mach/configure.in
parentb9cb349fb4fcec60fe99535dbab062ffe7a7ac49 (diff)
* configure.in (MIG): Just AC_SUBST it here.
* configure: Regenerated. * sysdeps/mach/configure.in (MIG): Do the AC_CHECK_TOOL here. Adding final - argument to all AC_CHECK_HEADER uses for .defs files. * sysdeps/mach/configure: Regenerated. * aclocal.m4 (GLIBC_PROVIDES): Add AC_PROVIDE([_AS_TR_SH_PREPARE]) and AC_PROVIDE([_AS_CR_PREPARE]).
Diffstat (limited to 'sysdeps/mach/configure.in')
-rw-r--r--sysdeps/mach/configure.in12
1 files changed, 6 insertions, 6 deletions
diff --git a/sysdeps/mach/configure.in b/sysdeps/mach/configure.in
index 92b7777304..7a4b0e0766 100644
--- a/sysdeps/mach/configure.in
+++ b/sysdeps/mach/configure.in
@@ -1,16 +1,16 @@
sinclude(./aclocal.m4)dnl Autoconf lossage.
GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
-dnl Autoconf weirdness requires that AC_CHECK_TOOL be in the main configure.in,
-dnl but only on Mach-based configurations is the tool needed.
+AC_CHECK_TOOL(MIG, mig, MISSING)
if test "x$MIG" = xMISSING; then
AC_MSG_ERROR([cannot find required build tool mig])
fi
### Sanity checks for Mach header installation
-AC_CHECK_HEADER(mach/mach_types.h,, [AC_MSG_ERROR([cannot find Mach headers])])
+AC_CHECK_HEADER(mach/mach_types.h,,
+ [AC_MSG_ERROR([cannot find Mach headers])], -)
AC_CHECK_HEADER(mach/mach_types.defs,, [dnl
-AC_MSG_ERROR([cannot find Mach .defs files])])
+AC_MSG_ERROR([cannot find Mach .defs files])], -)
dnl
dnl mach_TYPE_CHECK(foo_t, bar_t)
@@ -61,7 +61,7 @@ for ifc in mach mach4 \
i386/mach_i386 \
; do
AC_CHECK_HEADER(mach/${ifc}.defs, [dnl
- mach_interface_list="$mach_interface_list $ifc"])
+ mach_interface_list="$mach_interface_list $ifc"],, -)
done
if test "x$mach_interface_list" = x; then
AC_MSG_ERROR([what manner of Mach is this?])
@@ -79,7 +79,7 @@ fi
AC_CHECK_HEADER(mach/machine/ndr_def.h, [dnl
DEFINES="$DEFINES -DNDR_DEF_HEADER='<mach/machine/ndr_def.h>'"], [dnl
AC_CHECK_HEADER(machine/ndr_def.h, [dnl
- DEFINES="$DEFINES -DNDR_DEF_HEADER='<machine/ndr_def.h>'"])])
+ DEFINES="$DEFINES -DNDR_DEF_HEADER='<machine/ndr_def.h>'"],, -)], -)
AC_CACHE_CHECK(for i386_io_perm_modify in mach_i386.defs,
libc_cv_mach_i386_ioports, [dnl