summaryrefslogtreecommitdiff
path: root/ports/sysdeps/mips/Makefile
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2012-07-01 13:08:59 +0000
committerJoseph Myers <joseph@codesourcery.com>2012-07-01 13:08:59 +0000
commite84eabb3871c9b39e59323bf3f6b98c2ca9d1cd0 (patch)
treedff3f1b79454b518d15a7b9bbedeb57ff156bbe8 /ports/sysdeps/mips/Makefile
parent75f0d3040a2c2de8842bfa7a09e11da1a73e17d0 (diff)
parente64ac02c24b43659048622714afdc92fedf561fa (diff)
Merge glibc-ports into ports/ directory.glibc-2.16-ports-merge
Diffstat (limited to 'ports/sysdeps/mips/Makefile')
-rw-r--r--ports/sysdeps/mips/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/ports/sysdeps/mips/Makefile b/ports/sysdeps/mips/Makefile
new file mode 100644
index 0000000000..a1526998e0
--- /dev/null
+++ b/ports/sysdeps/mips/Makefile
@@ -0,0 +1,28 @@
+ifeq ($(subdir),misc)
+sysdep_headers += regdef.h fpregdef.h sys/regdef.h sys/fpregdef.h \
+ sys/asm.h sgidefs.h
+endif
+
+ifeq ($(subdir),setjmp)
+sysdep_routines += setjmp_aux
+endif
+
+ifeq ($(subdir),rt)
+librt-sysdep_routines += rt-sysdep
+endif
+
+ifeq ($(subdir),debug)
+CFLAGS-backtrace.c += -funwind-tables
+endif
+
+ifeq ($(subdir),csu)
+CPPFLAGS-crti.S += $(pic-ccflag)
+CPPFLAGS-crtn.S += $(pic-ccflag)
+endif
+
+ifeq ($(subdir),nptl)
+CPPFLAGS-pt-crti.S += $(pic-ccflag)
+CPPFLAGS-crtn.S += $(pic-ccflag)
+endif
+
+ASFLAGS-.os += $(pic-ccflag)