summaryrefslogtreecommitdiff
path: root/ports/sysdeps/m68k/Makefile
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2012-07-01 13:08:59 +0000
committerJoseph Myers <joseph@codesourcery.com>2012-07-01 13:08:59 +0000
commite84eabb3871c9b39e59323bf3f6b98c2ca9d1cd0 (patch)
treedff3f1b79454b518d15a7b9bbedeb57ff156bbe8 /ports/sysdeps/m68k/Makefile
parent75f0d3040a2c2de8842bfa7a09e11da1a73e17d0 (diff)
parente64ac02c24b43659048622714afdc92fedf561fa (diff)
Merge glibc-ports into ports/ directory.glibc-2.16-ports-merge
Diffstat (limited to 'ports/sysdeps/m68k/Makefile')
-rw-r--r--ports/sysdeps/m68k/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/ports/sysdeps/m68k/Makefile b/ports/sysdeps/m68k/Makefile
new file mode 100644
index 0000000000..e2dd372847
--- /dev/null
+++ b/ports/sysdeps/m68k/Makefile
@@ -0,0 +1,34 @@
+# Copyright (C) 1993, 1994, 1996, 1997, 2003 Free Software Foundation, Inc.
+# This file is part of the GNU C Library.
+
+# The GNU C Library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License, or (at your option) any later version.
+
+# The GNU C Library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+
+# You should have received a copy of the GNU Lesser General Public
+# License along with the GNU C Library. If not, see
+# <http://www.gnu.org/licenses/>.
+
+# The mpn functions need this. All existing 68k ports use MIT syntax. If
+# a new port wants to use Motorola or Sony syntax, it can redefine this
+# variable.
+ifndef m68k-syntax-flag
+m68k-syntax-flag = -DMIT_SYNTAX
+endif
+
+asm-CPPFLAGS += $(m68k-syntax-flag)
+
+pic-ccflag = -fpic
+
+# Make sure setjmp.c is compiled with a frame pointer
+CFLAGS-setjmp.c := -fno-omit-frame-pointer
+
+ifeq ($(subdir),elf)
+CFLAGS-rtld.c += -Wno-uninitialized -Wno-unused
+endif