summaryrefslogtreecommitdiff
path: root/ports/sysdeps/ia64/fpu/Makefile
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2012-07-01 13:08:59 +0000
committerJoseph Myers <joseph@codesourcery.com>2012-07-01 13:08:59 +0000
commite84eabb3871c9b39e59323bf3f6b98c2ca9d1cd0 (patch)
treedff3f1b79454b518d15a7b9bbedeb57ff156bbe8 /ports/sysdeps/ia64/fpu/Makefile
parent75f0d3040a2c2de8842bfa7a09e11da1a73e17d0 (diff)
parente64ac02c24b43659048622714afdc92fedf561fa (diff)
Merge glibc-ports into ports/ directory.glibc-2.16-ports-merge
Diffstat (limited to 'ports/sysdeps/ia64/fpu/Makefile')
-rw-r--r--ports/sysdeps/ia64/fpu/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/ports/sysdeps/ia64/fpu/Makefile b/ports/sysdeps/ia64/fpu/Makefile
new file mode 100644
index 0000000000..384fc836af
--- /dev/null
+++ b/ports/sysdeps/ia64/fpu/Makefile
@@ -0,0 +1,34 @@
+ifeq ($(subdir),math)
+#
+# Some files which need to go both into libc and libm have external
+# dependencies which need to be resolved differently for libc
+# vs. libm. For example, inside libc, __libm_error_support needs to
+# resolve to HIDDEN_JUMPTARGET(__libm_error_support) whereas within
+# libm it always resolves to __libm_error_support. Such files need to
+# be compiled twice. Fortunately, math/Makefile already has logic to
+# support this: if a file starts with "s_", make will automatically
+# generate a matching file whose name starts with "m_" which simply
+# includes the corresponding "s_" file.
+#
+duplicated-routines = s_libm_ldexp s_libm_ldexpf s_libm_ldexpl \
+ s_libm_scalbn s_libm_scalbnf s_libm_scalbnl
+
+libm-sysdep_routines += s_erfc s_erfcf s_erfcl \
+ s_matherrf s_matherrl libm_reduce \
+ libm_error \
+ libm_frexp libm_frexpf libm_frexpl \
+ libm_sincos libm_sincosf libm_sincosl \
+ libm_sincos_large \
+ libm_lgamma libm_lgammaf libm_lgammal \
+ libm_scalblnf \
+ $(duplicated-routines:s_%=m_%)
+
+sysdep_routines += libc_libm_error libm_frexp libm_frexpf libm_frexpl \
+ $(duplicated-routines)
+
+sysdep-CPPFLAGS += -include libm-symbols.h \
+ -D__POSIX__ -Dopensource \
+ -D_LIB_VERSIONIMF=_LIB_VERSION \
+ -DSIZE_INT_32 -DSIZE_LONG_INT_64 -DSIZE_LONG_LONG_INT_64 \
+ -DSIZE_LONG_64 -DIA64
+endif