summaryrefslogtreecommitdiff
path: root/ports/sysdeps/alpha/soft-fp/Makefile
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2012-07-01 13:06:41 +0000
committerJoseph Myers <joseph@codesourcery.com>2012-07-01 13:06:41 +0000
commite64ac02c24b43659048622714afdc92fedf561fa (patch)
tree37162878b72d302de351788bec4c9360c9d55f1d /ports/sysdeps/alpha/soft-fp/Makefile
parenta20c2b3c87aebc7d4b090c622d36480263b80042 (diff)
Move all files into ports/ subdirectory in preparation for merge with glibc
Diffstat (limited to 'ports/sysdeps/alpha/soft-fp/Makefile')
-rw-r--r--ports/sysdeps/alpha/soft-fp/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/ports/sysdeps/alpha/soft-fp/Makefile b/ports/sysdeps/alpha/soft-fp/Makefile
new file mode 100644
index 0000000000..5410a78984
--- /dev/null
+++ b/ports/sysdeps/alpha/soft-fp/Makefile
@@ -0,0 +1,10 @@
+# Software floating-point emulation.
+
+ifeq ($(subdir),soft-fp)
+sysdep_routines += ots_add ots_sub ots_mul ots_div ots_cmp ots_cmpe \
+ ots_cvtxq ots_cvtqx ots_cvtqux ots_cvttx ots_cvtxt ots_nintxq
+endif
+
+ifeq ($(subdir),math)
+CPPFLAGS += -I../soft-fp
+endif