summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@hack.frob.com>2012-08-22 13:35:55 -0700
committerRoland McGrath <roland@hack.frob.com>2012-08-22 13:35:55 -0700
commitc53d909c80a6c61a96e488b7efc0b1d41d56a4ea (patch)
tree657bd84a3214797bdc56201fca26fe9e92ce6713 /configure.in
parent3cc3ef96d6c060e9d45b43f5482dc4e03945b30e (diff)
Add --disable-build-nscd configure option.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a5ce139de4..a5d9dea118 100644
--- a/configure.in
+++ b/configure.in
@@ -293,6 +293,13 @@ void foo (int i, void *p)
fi
fi
+AC_ARG_ENABLE([build-nscd],
+ [AS_HELP_STRING([--disable-build-nscd],
+ [disable building and installing the nscd daemon])],
+ [build_nscd=$enableval],
+ [build_nscd=default])
+AC_SUBST(build_nscd)
+
# Note the use of $use_nscd is near the bottom of the file.
AC_ARG_ENABLE([nscd],
[AS_HELP_STRING([--disable-nscd],
@@ -2112,6 +2119,9 @@ AC_SUBST(use_nscd)
if test "x$use_nscd" != xno; then
AC_DEFINE([USE_NSCD])
fi
+if test "x$build_nscd" = xdefault; then
+ build_nscd=$use_nscd
+fi
# Test for old glibc 2.0.x headers so that they can be removed properly
# Search only in includedir.