summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorH.J. Lu <hjl.tools@gmail.com>2013-01-11 07:14:18 -0800
committerH.J. Lu <hjl.tools@gmail.com>2013-01-11 07:14:18 -0800
commit740b3dbee8ef034019b240dc4838b39dfa0c01e2 (patch)
tree6b4caa77b597058c873bd5df2e0f7a859327c90a /configure.in
parentc6fe55cf6089fc5cf1cea15fc7e1c9a8b90d9fda (diff)
Add --enable-hardcoded-path-in-tests configure option
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 96da720426..4e584c6a45 100644
--- a/configure.in
+++ b/configure.in
@@ -146,6 +146,13 @@ else
fi
AC_SUBST(oldest_abi)
+AC_ARG_ENABLE([hardcoded-path-in-tests],
+ AC_HELP_STRING([--enable-hardcoded-path-in-tests],
+ [hardcode newly built glibc path in tests @<:@default=no@:>@]),
+ [hardcoded_path_in_tests=$enableval],
+ [hardcoded_path_in_tests=no])
+AC_SUBST(hardcoded_path_in_tests)
+
AC_ARG_ENABLE([stackguard-randomization],
AC_HELP_STRING([--enable-stackguard-randomization],
[initialize __stack_chk_guard canary with a random number at program start]),