summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>2002-10-19 20:51:15 +0000
committerRoland McGrath <roland@gnu.org>2002-10-19 20:51:15 +0000
commita1ceed7aa29c1db5c7cd0c740a253899b6954630 (patch)
tree653fb7e5220d42bd742352034fcbbd87fa755932 /configure.in
parentf4b07664fb98e866ac8c97442118b32583b02071 (diff)
* configure.in: Call AC_CONFIG_SUBDIRS with empty argument
and then set $subdirs directly, because the new Autoconf breaks compatibility in every way imaginable and insists on whining about usage that worked since the dawn of time. * configure: Regenerated.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 3af6d1c09f..df18b8b935 100644
--- a/configure.in
+++ b/configure.in
@@ -157,7 +157,7 @@ if test "x$hidden" = xno; then
AC_DEFINE(NO_HIDDEN)
fi
-AC_CONFIG_SUBDIRS($add_ons)
+AC_CONFIG_SUBDIRS([ ])dnl Bonehead new Autoconf whines if we do it cleanly.
add_ons_pfx=
if test x"$add_ons" != x; then
for f in $add_ons; do
@@ -179,6 +179,10 @@ if test x"$add_ons" != x; then
# Test whether such a subdir really exists.
if test -d $srcdir/$f; then
add_ons_pfx="$add_ons_pfx $f/"
+ dnl This variable is what AC_CONFIG_SUBDIRS is supposed to set,
+ dnl but the new Autoconf maintainers don't care about compatibility
+ dnl so we cannot use it normally any more without complaints.
+ subdirs="$subdirs $f"
else
AC_MSG_ERROR(add-on directory \"$f\" does not exist)
fi