summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndreas Jaeger <aj@suse.de>2012-05-10 20:16:53 +0200
committerAndreas Jaeger <aj@suse.de>2012-05-10 20:19:53 +0200
commit021db4be6f1f4189f66feee066a495d49e92b93e (patch)
tree38d877e5dcba27bb3495cc840bc14b1a3547a076 /configure.in
parentb5c086a2814b45e0b2ab678922fcc66c7351fece (diff)
Make sunrpc code usable again
New configure option --enable-obsolete-rpc makes the deprecated RPC headers and functions available at compile time as they were before version 2.14. This option will be removed at some time in the future after the TI-RPC library becomes fully sufficient for the needs of existing applications.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 19a2c1a0f0..4eb9277e8c 100644
--- a/configure.in
+++ b/configure.in
@@ -252,6 +252,17 @@ else
fi
AC_SUBST(libc_cv_nss_crypt)
+AC_ARG_ENABLE([obsolete-rpc],
+ AC_HELP_STRING([--enable-obsolete-rpc],
+ [build and install the obsolete RPC code for link-time usage]),
+ [link_obsolete_rpc=$enableval],
+ [link_obsolete_rpc=no])
+AC_SUBST(link_obsolete_rpc)
+
+if test "$link_obsolete_rpc" = yes; then
+ AC_DEFINE(LINK_OBSOLETE_RPC)
+fi
+
# The way shlib-versions is used to generate soversions.mk uses a
# fairly simplistic model for name recognition that can't distinguish
# i486-pc-linux-gnu fully from i486-pc-gnu. So we mutate a $host_os