summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>2002-11-19 22:14:48 +0000
committerRoland McGrath <roland@gnu.org>2002-11-19 22:14:48 +0000
commitcd92532749dafc2e3694264131245ab354de4546 (patch)
tree74389e4e3ef8dfbcdbae8485927f107831dde82e /configure.in
parent3c857306f53bad2003c418ac79303bd65f626424 (diff)
2002-11-19 Roland McGrath <roland@redhat.com>
* configure.in (libc_cv_gcc_dwarf2_unwind_info check): Use libraries `-lgcc -lgcc_eh -lgcc', not just `-lgcc -lgcc_eh' in link commands for test leading to libc_cv_gcc_dwarf2_unwind_info=no_registry_needed. * configure: Regenerated.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 9dc94f50e6..2804c3f8b1 100644
--- a/configure.in
+++ b/configure.in
@@ -1544,11 +1544,12 @@ if AC_TRY_COMMAND([${CC-cc} $CFLAGS -DCHECK__register_frame_info
else
libc_cv_gcc_dwarf2_unwind_info=no
fi
-if AC_TRY_COMMAND([${CC-cc} $CFLAGS -DCHECK__register_frame_info
- -nostdlib -nostartfiles
- -o conftest conftest.c -lgcc -lgcc_eh >&AS_MESSAGE_LOG_FD]); then
- if ${CC-cc} $CFLAGS -DCHECK__register_frame_info -nostdlib -nostartfiles \
- -o conftest conftest.c -lgcc -lgcc_eh -v 2>&1 >/dev/null \
+# Some platforms' specs put -lgcc first. The second one doesn't hurt.
+libc_unwind_check="${CC-cc} $CFLAGS -DCHECK__register_frame_info \
+ -nostdlib -nostartfiles -o conftest conftest.c \
+ -lgcc -lgcc_eh -lgcc"
+if AC_TRY_COMMAND([$libc_unwind_check >&AS_MESSAGE_LOG_FD]); then
+ if $libc_unwind_check -v 2>&1 >/dev/null \
| grep -q -- --eh-frame-hdr; then
libc_cv_gcc_dwarf2_unwind_info=no_registry_needed
else