summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>1996-12-09 03:15:25 +0000
committerUlrich Drepper <drepper@redhat.com>1996-12-09 03:15:25 +0000
commitfeb3c934355a9a2331cdfeb7ab6351fd4856164f (patch)
treec471eb93237700d90a63c8448e8b99a2ecb23dd0 /configure.in
parentf65fd747b440ae2d8a7481ecc50e668c5e4d0cc9 (diff)
update from main archive 961208cvs/libc-961209
Mon Dec 9 03:39:30 1996 Ulrich Drepper <drepper@cygnus.com> * config.make.in (defines): Add @USE_NEW_MALLOC@. * Makefile.in: Define USE_NEW_MALLOC to -DUSE_NEW_MALLOC if we use the new malloc. * malloc.h: Use either <malloc/malloc.h> or <new-malloc/malloc.h> depending on USE_NEW_MALLOC. Fix some more POSIX.1 problems. * libio/fileops.c (_IO_file_underflow): Set errno to EBADF if used on a write-only stream. (_IO_file_overflow): Set errno to EBADF if used on a read-only stream. (_IO_file_seekoff): POSIX.1 requires that fseek() after an fflush() call really positions the file offset to the correct position and no read-ahead happens. * locale/C-monetary.c: Set mon_grouping file to "" and "\377" to pass POSIX test suite. * stdio-common/vfprintf.c: Handle empty string as grouping command correctly. * stdlib/grouping.h: Likewise. * misc/syslog.c: Case first argument of __libc_cleanup_region_start. * signal/sigsetops.h: Update copyright. Don't include ansidecl.h. * stdio-common/printf_fp.c: Update copyright. Sun Dec 8 16:39:28 1996 Andreas Jaeger <aj@arthur.pfalz.de> * time/Makefile: Compile ap.c with NO_MCHECK flag if new-malloc used (not otherwise). * misc/syslog.c (vsyslog): Cast argument to __libc_cleanup_region to get Hurd macros right.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 70d62b41c0..2c11732598 100644
--- a/configure.in
+++ b/configure.in
@@ -689,7 +689,11 @@ AC_MSG_RESULT($stdio)
AC_MSG_CHECKING(malloc selection)
AC_SUBST(malloc)
-test $malloc = default && malloc=malloc
+case $malloc in
+new-malloc) USE_NEW_MALLOC=-DUSE_NEW_MALLOC ;;
+default) malloc=malloc ;;
+esac
+AC_SUBST(USE_NEW_MALLOC)
AC_MSG_RESULT($malloc)