summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>1996-06-14 12:05:04 +0000
committerRoland McGrath <roland@gnu.org>1996-06-14 12:05:04 +0000
commitf332db025658c36adaad3759d438ef5117a595c8 (patch)
tree2991fb69f1636a5fdaac65487bdae343535bc6c8 /configure.in
parent9f70e81bcaa12b0673cd0879d6f4a21ad6dddce5 (diff)
Fri Jun 14 01:51:47 1996 Roland McGrath <roland@delasyd.gnu.ai.mit.edu>cvs/libc-960615
* version.c (banner): New static const variable, complete version banner text. (__libc_print_version): Use it, and use __write instead of printf. * configure.in (sysnames): Don't cache the value, because it depends only on libc sources. Merge uniquifying third pass into Implies/parent expansion second pass. Report each unique name as it is added in partial report string, terminated when finished. * Makeconfig (sysdep_dir): Move defn before config.status rule that expands it. (sysdep-configures): Variable removed. (config.status): Use its contents directly, tighten up a bit, and include Implies files. * elf/dl-open.c (_dl_open) [PIC]: Set PARENT to _dl_loaded if null. * elf/Makefile ($(objpfx)$(rtld-installed-name)): Make a symlink. * sysdeps/mach/hurd/dl-sysdep.c (_dl_sysdep_open_zero_fill): Add comment. * elf/rtld.c (dl_main): Close _dl_zerofd after mapping deps. * sysdeps/generic/machine-gmon.h [NO_UNDERSCORES]: Define mcount as weak alias for _mcount. * sysdeps/alpha/_mcount.S (mcount): Define as weak alias.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in46
1 files changed, 23 insertions, 23 deletions
diff --git a/configure.in b/configure.in
index e3154b6a7c..eceb4da989 100644
--- a/configure.in
+++ b/configure.in
@@ -118,8 +118,9 @@ changequote([,])dnl
AC_SUBST(base_machine)
# Compute the list of sysdep directories for this configuration.
+# This can take a while to compute.
sysdep_dir=$srcdir/sysdeps
-AC_CACHE_CHECK(sysdep dirs, libc_cv_sysdirs, [dnl
+AC_MSG_CHECKING(sysdep dirs)
dnl We need to use [ and ] for other purposes for a while now.
changequote(,)dnl
# Make sco3.2v4 become sco3.2.4 and sunos4.1.1_U1 become sunos4.1.1.U1.
@@ -232,15 +233,26 @@ sysnames="`echo $sysnames | sed -e 's@^/@@' -e 's@ /@ @g'`"
# Expand the list of system names into a full list of directories
# from each element's parent name and Implies file (if present).
set $sysnames
+names= seen=
while test $# -gt 0; do
name=$1
shift
+ if echo "$seen" | fgrep -x $name >/dev/null; then
+ # Already in the list.
+ continue
+ fi
+
+ # Report each name as we discover it, so there is no long pause in output.
+ echo $ac_n "$name $ac_c" >&AC_FD_MSG
+
if test -f $sysdep_dir/$name/Implies; then
# Collect more names from the `Implies' file (removing comments).
implied="`sed 's/#.*$//' < $sysdep_dir/$name/Implies`"
for x in $implied; do
- test -d $sysdep_dir/$x || echo "Warning: $name implies nonexistent $x">&2
+ test -d $sysdep_dir/$x || {
+ AC_MSG_WARN(sysdeps/$name/Implies specifies nonexistent $x)
+ }
done
else
implied=
@@ -248,6 +260,9 @@ while test $# -gt 0; do
# Add NAME to the list of names.
names="$names $name"
+ # We maintain a parallel newline-separated list for the fgrep check above.
+ seen="$seen
+$name"
# Find the parent of NAME, using the empty string if it has none.
changequote(,)dnl
@@ -266,28 +281,13 @@ changequote([,])dnl
done
# Add the default directories.
-names="$names generic stub"
+sysnames="$names generic stub"
+AC_SUBST(sysnames)
+# The other names were emitted during the scan.
+AC_MSG_RESULT(generic stub)
-# Now uniquize the list.
-seen=
-sysnames=
-for name in $names; do
- if echo "$seen" | fgrep -x $name >/dev/null; then
- # Already in the list.
- true;
- else
- # A new one.
- if test -z "$seen"; then
- seen="$name" sysnames="$name"
- else
- seen="$seen
-$name"
- sysnames="$sysnames $name"
- fi
- fi
-done
-libc_cv_sysdirs="$sysnames"])
-AC_SUBST(sysnames) sysnames="$libc_cv_sysdirs"
+
+### Locate tools.
AC_PROG_INSTALL
if test "$INSTALL" = "${srcdir}/install-sh"; then