summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>2005-12-28 06:53:43 +0000
committerRoland McGrath <roland@gnu.org>2005-12-28 06:53:43 +0000
commitef226fecbeae89451529fc9094b4a2c2387f6884 (patch)
tree7025a6763491faddc4e48fbc3faa25c7f519e5ba /configure.in
parentdb169ed561acef18093cc6739fb159d6274bf5a5 (diff)
* config.make.in (c++-sysincludes): New substituted variable.
* configure.in (CXX_SYSINCLUDES): New substituted variable. * configure: Regenerated. * Makeconfig (CXXFLAGS): Prepend $(c++-sysincludes) here.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ba7ca30b2f..4ae30ae2c9 100644
--- a/configure.in
+++ b/configure.in
@@ -838,8 +838,16 @@ if test -n "$sysheaders"; then
ccheaders=`$CC -print-file-name=include`
SYSINCLUDES="-nostdinc -isystem $ccheaders \
-isystem `echo $sysheaders | sed 's/:/ -isystem /g'`"
+ if test -n "$CXX"; then
+ cxxversion=`$CXX -dumpversion 2>&AS_MESSAGE_LOG_FD` &&
+ cxxmachine=`$CXX -dumpmachine 2>&AS_MESSAGE_LOG_FD` &&
+ cxxheaders=`$CXX -print-file-name=../../../../include/c++/`"$cxxversion" &&
+ CXX_SYSINCLUDES="-isystem $cxxheaders \
+-isystem $cxxheaders/$cxxmachine -isystem $cxxheaders/backward"
+ fi
fi
AC_SUBST(SYSINCLUDES)
+AC_SUBST(CXX_SYSINCLUDES)
# check if ranlib is necessary
AC_CACHE_CHECK(whether ranlib is necessary, libc_cv_ranlib_necessary, [dnl