summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>2005-06-14 22:52:30 +0000
committerUlrich Drepper <drepper@redhat.com>2005-06-14 22:52:30 +0000
commitec23b9bece4780a2031eedf23019cbb229e855fb (patch)
treec4a5eb2239fc514124a9ffae30ed7530239d1a5f /configure.in
parent0e66ade5ada897fe4b8be8d9c05c5519e7be4199 (diff)
* configure.in: Add test for availability of libaudit.
* config.h.in: Define HAVE_LIBAUDIT. * config.make.in: Define have-libaudit. * nscd/Makefile: If libaudit is available, link nscd with it. * nscd/selinux.c: If HAVE_LIBAUDIT is defined, log using libaudit. Patch by Steve Grubb <sgrubb@redhat.com>.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 503611a6b9..5f46b5e4ef 100644
--- a/configure.in
+++ b/configure.in
@@ -1938,6 +1938,14 @@ fi
# Check if we're building with SELinux support.
if test "x$have_selinux" = xyes; then
AC_DEFINE(HAVE_SELINUX,1,[SELinux support])
+
+ # See if we have the libaudit library
+ AC_CHECK_LIB(audit, audit_log_avc,
+ have_libaudit=yes, have_libaudit=no)
+ if test "x$have_libaudit" = xyes; then
+ AC_DEFINE(HAVE_LIBAUDIT,1,[SELinux libaudit support])
+ fi
+ AC_SUBST(have_libaudit)
fi
AC_SUBST(have_selinux)