summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>1997-06-16 00:14:00 +0000
committerUlrich Drepper <drepper@redhat.com>1997-06-16 00:14:00 +0000
commite7f1f046f51d95d5d05ada3abd3f2e88219118e9 (patch)
tree1095d104b90bb6f85faa927c1eca7d2b47d3e63b /configure.in
parent900bec852d0bd53eb27b8b2193899f5cf470b38f (diff)
1997-06-16 00:54 Ulrich Drepper <drepper@cygnus.com> * libc.map: Add more symbols. * Mwkerules (load-map-file): Currectly handle missing map file. 1997-06-15 17:00 Philip Blundell <Philip.Blundell@pobox.com> * configure.in: Correct detection of generic uname implementation. 1997-06-15 23:19 Ulrich Drepper <drepper@cygnus.com> * math/libm-test.c: Fix typos. Patch by Andreas Jaeger. * libc.map: Add __nss_configure_lookup. Reported by Thorsten Kukuk.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index a06fa35db2..667ac7e0c2 100644
--- a/configure.in
+++ b/configure.in
@@ -703,10 +703,10 @@ for dir in $sysnames; do
fi
[
if test -z "$uname"; then
- if test -r $sysdep_dir/$dir/uname.c ||
- test -r $sysdep_dir/$dir/uname.S ||
- { test -r $sysdep_dir/$dir/syscalls.list &&
- grep '^uname[ ]' $sysdep_dir/$dir/syscalls.list >/dev/null; }; then
+ if test -r $dest/uname.c ||
+ test -r $dest/uname.S ||
+ { test -r $dest/syscalls.list &&
+ grep '^uname[ ]' $dest/syscalls.list >/dev/null; }; then
uname=$dir
fi
fi
@@ -717,7 +717,7 @@ AC_LINK_FILES(`echo $libc_link_sources`, `echo $libc_link_dests`)
# If we will use the generic uname implementation, we must figure out what
# it will say by examining the system, and write the results in config-name.h.
-if test "$uname" = generic; then
+if test "$uname" = "sysdeps/generic"; then
changequote(,)dnl
uname_sysname=`echo $config_os | sed 's/[0-9.]*$//'`