summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>2006-01-04 06:26:39 +0000
committerUlrich Drepper <drepper@redhat.com>2006-01-04 06:26:39 +0000
commit943db9eb6417433fd2dd82521933b21f4bf211b8 (patch)
treec73efb54722b1cd1bc19f27c634ae6add86e009a /configure.in
parentb01fe5f792564a4f6606f33f7827b649bdfbd1f4 (diff)
* configure.in (HAVE_LIBAUDIT): Check
audit_log_user_avc_message instead of audit_log_avc. 2006-01-04 Joseph S. Myers <joseph@codesourcery.com> * sysdeps/ieee754/bits/nan.h: Fix typo.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 4ae30ae2c9..1199ac00ea 100644
--- a/configure.in
+++ b/configure.in
@@ -1956,13 +1956,13 @@ else
fi
# Check if we're building with SELinux support.
if test "x$have_selinux" = xyes; then
- AC_DEFINE(HAVE_SELINUX,1,[SELinux support])
+ AC_DEFINE(HAVE_SELINUX, 1, [SELinux support])
# See if we have the libaudit library
- AC_CHECK_LIB(audit, audit_log_avc,
- have_libaudit=yes, have_libaudit=no)
+ AC_CHECK_LIB(audit, audit_log_user_avc_message,
+ have_libaudit=yes, have_libaudit=no)
if test "x$have_libaudit" = xyes; then
- AC_DEFINE(HAVE_LIBAUDIT,1,[SELinux libaudit support])
+ AC_DEFINE(HAVE_LIBAUDIT, 1, [SELinux libaudit support])
fi
AC_SUBST(have_libaudit)
fi