summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>2005-03-06 00:26:34 +0000
committerUlrich Drepper <drepper@redhat.com>2005-03-06 00:26:34 +0000
commit93aed66714e2cadb4847162d626c7823e37230d3 (patch)
treef67b21d7e3f6fd22cc712d147d937f1a41bd3e70 /configure.in
parent171129215cd04bf3e5986c7b1f762a018d5c80e0 (diff)
* sunrpc/key_call.c: Remove doors support.
* sunrpc/Makefile: Remove CPPFLAGS-key_call.c definition. * configure.in: Remove test for doors support which never existed. * config.make.in: Remove have_doors entry. * configure.in: Make sure at least gcc 3.4 is used. Undo last change. * config.make.in: Undo last change. * sysdeps/i386/Makefile ((CFLAGS-initfini.s): Unconditionally use -mtune. * sysdeps/i386/dl-machine.h (ELF_MACHINE_NO_RELA): Define unconditionally to (defined RTLD_BOOTSTRAP). * sysdeps/arm/dl-machine.h (ELF_MACHINE_NO_RELA): Likewise. 2005-03-05 Jakub Jelinek <jakub@redhat.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 1 insertions, 23 deletions
diff --git a/configure.in b/configure.in
index 6ec23d5c1c..f5defbfe8c 100644
--- a/configure.in
+++ b/configure.in
@@ -760,7 +760,7 @@ fi
# These programs are version sensitive.
AC_CHECK_TOOL_PREFIX
AC_CHECK_PROG_VER(CC, ${ac_tool_prefix}gcc ${ac_tool_prefix}cc, -v,
- [version \([egcygnustpi-]*[0-9.]*\)], [3.[2-9]* | 4.[0-9]* ],
+ [version \([egcygnustpi-]*[0-9.]*\)], [3.4* | 4.[0-9]* ],
critic_missing="$critic_missing gcc")
AC_CHECK_PROG_VER(MAKE, gnumake gmake make, --version,
[GNU Make[^0-9]*\([0-9][0-9.]*\)],
@@ -2116,22 +2116,6 @@ fi
rm -f conftest.*])
AC_SUBST(pic_default)
-# This test comes after sysdeps configure fragments, so that they can
-# define the variable libc_mtune_example to tell us a valid -mtune=value
-# argument that we can test with.
-AC_SUBST(cc_mtune)cc_mtune=-mcpu
-if test "x$libc_mtune_example" != x; then
- AC_CACHE_CHECK(if compiler supports -mtune option, libc_cv_cc_mtune, [dnl
- libc_cv_cc_mtune=no
- save_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS -mtune=$libc_mtune_example"
- AC_TRY_COMPILE(,,[libc_cv_cc_mtune=yes])
- ])
- if test "x$libc_cv_cc_mtune" = xyes; then
- cc_mtune=-mtune
- fi
-fi
-
AC_SUBST(profile)
AC_SUBST(omitfp)
AC_SUBST(bounded)
@@ -2140,12 +2124,6 @@ AC_SUBST(nopic_initfini)
AC_SUBST(DEFINES)
-case "$add_ons" in
- *door*) linux_doors=yes ;;
- *) linux_doors=no ;;
-esac
-AC_SUBST(linux_doors)
-
dnl See sysdeps/mach/configure.in for this variable.
AC_SUBST(mach_interface_list)