summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>2005-03-06 00:08:10 +0000
committerRoland McGrath <roland@gnu.org>2005-03-06 00:08:10 +0000
commit2103c260f999160d0abae3a594b8b712b3935395 (patch)
treeb9325feeb1a90539c5f26d62ce2906121b1e8526 /configure.in
parent3ff37e899a3fbb0c21ab6a2c5ab126b419326071 (diff)
* sysdeps/generic/ldsodefs.h (_dl_out_of_memory_internal): Remove decl.
(_dl_out_of_memory): Use rtld_hidden_proto. * elf/dl-error.c (_dl_out_of_memory): Use rtld_hidden_data_def. (_dl_signal_error): Don't use INTUSE on _dl_out_of_memory. * elf/dl-open.c (_dl_open): Likewise. * elf/dl-deps.c (_dl_map_object_deps): Likewise. * sunrpc/des_impl.c (des_set_key): Make first argument unsigned char *. * elf/dl-addr.c (_dl_addr): Add a cast. * elf/unload3mod4.c: Declare foo. * elf/testobj2.c: Include <stdio.h>. * sysdeps/gnu/errlist.awk: Emit NERR macro for _sys_nerr_internal value constant, and use it in the defn. * sysdeps/gnu/errlist-compat.awk: Use NERR in array decl. Use actual size for compat array decls. * config.make.in (cc-mtune): New substituted variable. * configure.in (libc_cv_cc_mtune): New test for -mtune= switch, done only if libc_mtune_example is defined. * configure: Regenerated. * sysdeps/i386/configure.in (libc_mtune_example): Set it. * sysdeps/i386/configure: Regenerated. * sysdeps/i386/Makefile (CFLAGS-initfini.s): Use $(cc-mtune).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 11f78b0ec3..6ec23d5c1c 100644
--- a/configure.in
+++ b/configure.in
@@ -2116,6 +2116,22 @@ fi
rm -f conftest.*])
AC_SUBST(pic_default)
+# This test comes after sysdeps configure fragments, so that they can
+# define the variable libc_mtune_example to tell us a valid -mtune=value
+# argument that we can test with.
+AC_SUBST(cc_mtune)cc_mtune=-mcpu
+if test "x$libc_mtune_example" != x; then
+ AC_CACHE_CHECK(if compiler supports -mtune option, libc_cv_cc_mtune, [dnl
+ libc_cv_cc_mtune=no
+ save_CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS -mtune=$libc_mtune_example"
+ AC_TRY_COMPILE(,,[libc_cv_cc_mtune=yes])
+ ])
+ if test "x$libc_cv_cc_mtune" = xyes; then
+ cc_mtune=-mtune
+ fi
+fi
+
AC_SUBST(profile)
AC_SUBST(omitfp)
AC_SUBST(bounded)