summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2012-03-21 16:33:57 +0000
committerJoseph Myers <joseph@codesourcery.com>2012-03-21 16:33:57 +0000
commit40b601fbb774cd2be2f6cbe7155570340fc475a2 (patch)
tree79ec38289fe7e9a56059c8c69e8b212eb218e3f0 /configure.in
parent1a4ac776ebc9bb07287f59f63e473db531318dff (diff)
Use autoconf macro for testing compiler options with empty input.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index ee5e856306..bb3b057a36 100644
--- a/configure.in
+++ b/configure.in
@@ -2005,10 +2005,9 @@ if test -n "$submachine"; then
libc_cv_cc_submachine, [dnl
libc_cv_cc_submachine=no
for opt in "-march=$submachine" "-mcpu=$submachine"; do
- if AC_TRY_COMMAND([${CC-cc} $opt -xc /dev/null -S -o /dev/null]); then
+ LIBC_TRY_CC_OPTION([$opt], [
libc_cv_cc_submachine="$opt"
- break
- fi
+ break], [])
done])
if test "x$libc_cv_cc_submachine" = xno; then
AC_MSG_ERROR([${CC-cc} does not support $submachine])