summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorThomas Schwinge <thomas@codesourcery.com>2013-01-25 12:44:45 +0100
committerThomas Schwinge <thomas@codesourcery.com>2013-01-25 12:44:45 +0100
commitb5a5da237648077c98c10d359fe3b62b9e18f811 (patch)
tree4fd1027638380d6c6cc32082dff03bafad430b9a /configure.in
parentbb931195fe780bb63e3d57d0742abad1d2128424 (diff)
Don't bother checking for $CC option to accept ISO C89.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2c50d0940f..c57897974c 100644
--- a/configure.in
+++ b/configure.in
@@ -34,6 +34,11 @@ fi
AC_SUBST(CPP)dnl
])# AC_PROG_CPP
+# We require GCC. Override _AC_PROG_CC_C89 here to work around the Autoconf
+# issue discussed in
+# <http://sourceware.org/ml/libc-alpha/2013-01/msg00757.html>.
+AC_DEFUN([_AC_PROG_CC_C89], [[$1]])
+
dnl This is here so we can set $subdirs directly based on configure fragments.
AC_CONFIG_SUBDIRS()