summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMarek Polacek <polacek@redhat.com>2012-07-10 14:30:24 +0200
committerMarek Polacek <polacek@redhat.com>2012-07-10 14:30:24 +0200
commit7b8e0d49cbfd8a911978d4b72f3d97e11a6d34ec (patch)
treeb6e8d0b491e2e4e78d1e4b41d3edadeb04392395 /configure.in
parentc1d00790348352d9bd342b9cebe70cb416f63798 (diff)
Get rid of ASM_GLOBAL_DIRECTIVE.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 5 insertions, 26 deletions
diff --git a/configure.in b/configure.in
index 5028e6411e..6b6dde5a83 100644
--- a/configure.in
+++ b/configure.in
@@ -581,34 +581,13 @@ else
AC_MSG_RESULT(yes)
fi
-AC_CACHE_CHECK(for assembler global-symbol directive,
- libc_cv_asm_global_directive, [dnl
-libc_cv_asm_global_directive=UNKNOWN
-for ac_globl in .globl .global .EXPORT; do
- cat > conftest.s <<EOF
- ${libc_cv_dot_text}
- ${ac_globl} foo
-foo:
-EOF
- if AC_TRY_COMMAND(${CC-cc} $ASFLAGS -c conftest.s 1>&AS_MESSAGE_LOG_FD); then
- libc_cv_asm_global_directive=${ac_globl}
- fi
- rm -f conftest*
- test $libc_cv_asm_global_directive != UNKNOWN && break
-done])
-if test $libc_cv_asm_global_directive = UNKNOWN; then
- AC_MSG_ERROR(cannot determine asm global directive)
-else
- AC_DEFINE_UNQUOTED(ASM_GLOBAL_DIRECTIVE, ${libc_cv_asm_global_directive})
-fi
-
AC_CACHE_CHECK(for assembler .type directive prefix,
libc_cv_asm_type_prefix, [dnl
libc_cv_asm_type_prefix=no
for ac_try_prefix in '@' '%' '#'; do
cat > conftest.s <<EOF
${libc_cv_dot_text}
- ${libc_cv_asm_global_directive} foo
+ .globl foo
.type foo, ${ac_try_prefix}object
.size foo, 1
foo:
@@ -1121,7 +1100,7 @@ cat > conftest.s <<EOF
${libc_cv_dot_text}
foo:
.set glibc_conftest_frobozz,foo
-$libc_cv_asm_global_directive glibc_conftest_frobozz
+.globl glibc_conftest_frobozz
EOF
# The alpha-dec-osf1 assembler gives only a warning for `.set'
# (but it doesn't work), so we must do a linking check to be sure.
@@ -1778,7 +1757,7 @@ AC_CACHE_CHECK(for assembler .weak directive, libc_cv_asm_weak_directive,
[dnl
cat > conftest.s <<EOF
${libc_cv_dot_text}
-${libc_cv_asm_global_directive} foo
+.globl foo
foo:
.weak foo
.weak bar; bar = foo
@@ -1796,11 +1775,11 @@ if test $libc_cv_asm_weak_directive = no; then
[dnl
cat > conftest.s <<EOF
${libc_cv_dot_text}
-${libc_cv_asm_global_directive} foo
+.globl foo
foo:
.weakext bar foo
.weakext baz
-${libc_cv_asm_global_directive} baz
+.globl baz
baz:
EOF
if AC_TRY_COMMAND(${CC-cc} $ASFLAGS -c conftest.s 1>&AS_MESSAGE_LOG_FD); then