summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>1996-03-28 09:48:58 +0000
committerRoland McGrath <roland@gnu.org>1996-03-28 09:48:58 +0000
commitffcf96345f519a1a557b019271d4a62ec40f7eaa (patch)
tree7038c77b3f6be934c42d8e210f7fd651e2b4176b /configure.in
parent0393dfd6c22d4f3bb61c4650e4c22e87026b19bd (diff)
Thu Mar 28 03:00:43 1996 Roland McGrath <roland@whiz-bang.gnu.ai.mit.edu>cvs/libc-960328
* locale/nl_langinfo.c (nl_langinfo): Use DATA->values instead of DATA->strings. * Makerules (BUILD_CFLAGS): Remove $(common-objpfx) from config.h. * configure.in (.weakext check): Fix asm code to use .weakext instead of .weak! Fix bogus test calls. * configure: Regenerated.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index b2727d54f2..734c5ad324 100644
--- a/configure.in
+++ b/configure.in
@@ -451,7 +451,7 @@ cat > conftest.s <<EOF
${libc_cv_asm_global_directive} foo
foo: .long 0
.weakext foo
-.weak bar, foo
+.weakext bar, foo
EOF
if ${CC-cc} $CFLAGS -c conftest.s 2>/dev/null; then
libc_cv_asm_weakext_directive=yes
@@ -463,9 +463,9 @@ EOF
fi # no .weak
fi # not ELF
-if test $libc_cv_asm_weak_directive; then
+if test $libc_cv_asm_weak_directive = yes; then
AC_DEFINE(HAVE_ASM_WEAK_DIRECTIVE)
-elif test $libc_cv_asm_weakext_directive; then
+elif test $libc_cv_asm_weakext_directive = yes; then
AC_DEFINE(HAVE_ASM_WEAKEXT_DIRECTIVE)
fi