summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>1996-06-19 14:52:21 +0000
committerRoland McGrath <roland@gnu.org>1996-06-19 14:52:21 +0000
commite50ec9f91d798e00154dc089037b25e6de1fe894 (patch)
tree95fc29d943ad4cadd75d0f9c61c03a8d809e3a43 /configure.in
parenta1470b6f839addde3f8ee2c29a237aca21e62565 (diff)
Mon Jun 17 19:09:49 1996 Andreas Schwab <schwab@issan.informatik.uni-dortmund.de>
* Make-dist (+sysdeps): Move wildcard inside loop to avoid consing up a huge list just to discard most of it. * configure.in (sysnames): Avoid fgrep by using the case shell builtin. * Makeconfig (config.status): Fix dependency on Implies files.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 3 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index e8e9121efd..38efc2edea 100644
--- a/configure.in
+++ b/configure.in
@@ -233,15 +233,15 @@ sysnames="`echo $sysnames | sed -e 's@^/@@' -e 's@ /@ @g'`"
# Expand the list of system names into a full list of directories
# from each element's parent name and Implies file (if present).
set $sysnames
-names= seen=
+names=
while test $# -gt 0; do
name=$1
shift
- if echo "$seen" | fgrep -x $name >/dev/null; then
+ case " $names " in *" $name "*)
# Already in the list.
continue
- fi
+ esac
# Report each name as we discover it, so there is no long pause in output.
echo $ac_n "$name $ac_c" >&AC_FD_MSG
@@ -260,9 +260,6 @@ while test $# -gt 0; do
# Add NAME to the list of names.
names="$names $name"
- # We maintain a parallel newline-separated list for the fgrep check above.
- seen="$seen
-$name"
# Find the parent of NAME, using the empty string if it has none.
changequote(,)dnl