summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>1995-10-17 01:08:25 +0000
committerRoland McGrath <roland@gnu.org>1995-10-17 01:08:25 +0000
commitd17e960c2bb10746bda675deb88d8b496f834eba (patch)
treed1c57ef2366aaa53c1b0bd88267c1646966a042a /configure.in
parentdeab9deadc372fe1a367aef2e78c0d8f2885bf23 (diff)
* elf/Makefile (install-others): Add missing slash.
* elf/ldd.sh.in: Prepend `./' to relative file names so ld.so won't search LD_LIBRARY_PATH.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 239e7fd874..dbfb695a0b 100644
--- a/configure.in
+++ b/configure.in
@@ -43,7 +43,6 @@ AC_ARG_WITH(weak-symbols, dnl
AC_ARG_ENABLE(libio, dnl
[ --enable-libio build in GNU libio instead of GNU stdio],
stdio=libio, stdio=stdio)
-AC_SUBST(stdio)
dnl Arguments to enable or disable building the shared, profiled, and
dnl -fomit-frame-pointer libraries.
@@ -57,6 +56,13 @@ AC_ARG_ENABLE(omitfp, dnl
[ --enable-omitfp build undebuggable optimized library [default=no]],
omitfp=$enableval, omitfp=no)
+AC_MSG_CHECKING(stdio selection)
+AC_SUBST(stdio)
+if test $stdio = libio; then
+ AC_DEFINE(USE_IN_LIBIO)
+fi
+AC_MSG_RESULT($stdio)
+
AC_CANONICAL_HOST
# We keep the original values in `$config_*' and never modify them, so we
# can write them unchanged into config.make. Everything else uses
@@ -490,10 +496,6 @@ fi
AC_SUBST(profile)
AC_SUBST(omitfp)
-if test $stdio = libio; then
- AC_DEFINE(USE_IN_LIBIO)
-fi
-
if test "`(cd $srcdir; pwd)`" = "`pwd`"; then
config_makefile=
else