summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>1996-08-28 00:26:07 +0000
committerUlrich Drepper <drepper@redhat.com>1996-08-28 00:26:07 +0000
commitb236e99d90748f6caf77994e96dc5aaa48ce2993 (patch)
tree8cbcae49b6ae6a59e7e59784b3c7b750b76a5f37 /configure.in
parent0b72c47ecf998030603fa0140225b9a5fe36473c (diff)
Tue Aug 27 17:45:21 1996 Ulrich Drepper <drepper@cygnus.com> * Makerules: Add some test for correct version of GNU Make. * io/fcntl.h: Undo change from Mon Aug 26 22:22:17 1996. * sysdeps/unix/sysv/linux/fcntlbits.h: Place macros here instead. * sysdeps/generic/dl-sysdep.c: Initialize break address to avoid overwriting last page (OK, Roland). Tue Aug 27 16:20:37 1996 Ulrich Drepper <drepper@cygnus.com> * resolv/resolv.h: Update from BIND-4.9.5-T3A. * resolv/arpa/nameser.h: Likewise. * resolv/res_init.c: Likewise. * resolv/res_debug.c: Likewise. * resolv/res_mkquery.c: Likewise. Tue Aug 27 15:47:04 1996 Ulrich Drepper <drepper@cygnus.com> * elf/dl-error.c (catch): Define errstring element not as const. (_dl_catch_error): ERRSTRING argument is not const pointer. Initialize *ERRSTRING and *OBJNAME separately. * elf/link.h: Change prototype for `_dl_catch_error'. * elf/dl-load.c (_dl_map_object): Use separate variable for copied NAME to avoid `const' warning. * elf/dlerror.c: Make `last_errstring' variable not const pointer. * elf/rtld.c: Implement reading of /etc/ld.so.preload. This provides preloading even for SUID binaries. Add some more casts to avoid signed<->unsigned warnings. Tue Aug 27 15:40:28 1996 NIIBE Yutaka <gniibe@mri.co.jp> * posix/sys/types.h: Define loff_t. * sysdeps/unix/sysv/linux/gnu/types.h: Define __loff_t. Mon Aug 26 16:31:33 1996 Thomas Bushnell, n/BSG <thomas@gnu.ai.mit.edu> * sysdeps/mach/hurd/setitimer.c (setitimer_locked): Tolerate NEW being null; in that case don't touch the timer at all (but do return something in OLD if necessary). Mon Aug 26 13:35:16 1996 Thomas Bushnell, n/BSG <thomas@gnu.ai.mit.edu> * sysdeps/mach/hurd/i386/init-first.c (__libc_multiple_libcs): New variable. * sysdeps/i386/init-first.c: Likewise. * sysdeps/stub/init-first.c: Likewise.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a2668b9ff9..8939236641 100644
--- a/configure.in
+++ b/configure.in
@@ -497,6 +497,23 @@ fi
rm -f conftest*])
AC_SUBST(libc_cv_ld_no_whole_archive)dnl
+AC_CACHE_CHECK(for gcc -fno-exceptions, libc_cv_gcc_no_exceptions, [dnl
+cat > conftest.c <<\EOF
+_start () {}
+int __eh_pc;
+__throw () {}
+EOF
+dnl No \ in command here because it ends up inside ''.
+if AC_TRY_COMMAND([${CC-cc} $CFLAGS
+ -nostdlib -nostartfiles -fno-exceptions
+ -o conftest conftest.c]); then
+ libc_cv_gcc_no_exceptions=yes
+else
+ libc_cv_gcc_no_exceptions=no
+fi
+rm -f conftest*])
+AC_SUBST(libc_cv_gcc_no_exceptions)dnl
+
### End of automated tests.
### Now run sysdeps configure fragments.