summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>1996-03-25 17:48:26 +0000
committerRoland McGrath <roland@gnu.org>1996-03-25 17:48:26 +0000
commit857fa1b81d522573da671e54e5d3149698e54a0d (patch)
tree2bdd9c03003f918733781576b9a8c220fa36dc10 /configure.in
parent25c931a18c141a40af5297416182d011c0325b9f (diff)
Mon Mar 25 03:35:16 1996 Roland McGrath <roland@charlie-brown.gnu.ai.mit.edu>
* malloc/malloc.c (morecore): Don't attempt recursive realloc of info table when _heaplimit==0 during realloc growing large block. * MakeTAGS (extract): Remove /dev/null from xgettext command line. (text-srcs): New variable: extract only C sources from $(tags_sources). (po/$(domain).pot): Depend on that. If it's empty, cp /dev/null $@ instead of $(extract). * misc/Makefile (headers): Add iovec.h. * sysdeps/unix/sysv/linux/iovec.h: New file. * sysdeps/generic/iovec.h: New file. * misc/sys/uio.h (struct iovec): Type replaced with #include <iovec.h>. * configure.in (NO_UNDERSCORES check): Use AC_TRY_LINK instead of AC_TRY_COMPILE. * misc/sys/cdefs.h [__USE_BSD] (const, signed, volatile): Move these macros inside [! __STDC__]. * stdlib/rpmatch.c: New file. * stdlib/Makefile (routines): Add rpmatch. * stdlib/stdlib.h [__USE_SVID]: Declare rpmatch. * MakeTAGS (MSGJOIN): Variable removed. (po/SYS_libc.pot): Use $(XGETTEXT) instead of $(MSGJOIN). Wed Mar 20 20:08:46 1996 Andreas Schwab <schwab@issan.informatik.uni-dortmund.de> * sysdeps/unix/sysdep.h: Don't define C_SYMBOL_NAME. * sysdeps/unix/sysv/linux/m68k/sysdep.h: Don't define NO_UNDERSCORES.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 6f18093461..b2727d54f2 100644
--- a/configure.in
+++ b/configure.in
@@ -413,9 +413,9 @@ if test $elf = yes; then
libc_cv_asm_underscores=no
else
AC_CACHE_CHECK(for _ prefix on C symbol names, libc_cv_asm_underscores,
- [AC_TRY_COMPILE([asm ("_glibc_foobar:");], [glibc_foobar ();],
- libc_cv_asm_underscores=yes,
- libc_cv_asm_underscores=no)])
+ [AC_TRY_LINK([asm ("_glibc_foobar:");], [glibc_foobar ();],
+ libc_cv_asm_underscores=yes,
+ libc_cv_asm_underscores=no)])
fi
if test $libc_cv_asm_underscores = no; then
AC_DEFINE(NO_UNDERSCORES)