summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>1996-07-29 05:54:17 +0000
committerRoland McGrath <roland@gnu.org>1996-07-29 05:54:17 +0000
commit6b3a22241612763d4c36fc6f038fa073e528117a (patch)
tree619e507049baf479f7b8641f631be70eb19022a1 /configure.in
parentce7a5ef4bc04ee3ca9d2f42377ca6593d8492a52 (diff)
Mon Jul 29 01:27:07 1996 Roland McGrath <roland@delasyd.gnu.ai.mit.edu>cvs/libc-960730cvs/libc-960729
* sunrpc/rpc/rpc_msg.h: Fix botched patch for multiple inclusion protection. * configure.in: Grok `--enable-add-ons=DIR1,DIR2,...', and configure in those directories. * config.make.in (add-ons): New varaible, set from @subdirs@. * Makefile (subdirs): Added $(add-ons) at the end.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 11 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index a8870c9c75..f1d3d9b0ca 100644
--- a/configure.in
+++ b/configure.in
@@ -63,13 +63,20 @@ dnl Arguments to enable or disable building the shared, profiled, and
dnl -fomit-frame-pointer libraries.
AC_ARG_ENABLE(shared, dnl
[ --enable-shared build shared library [default=yes if GNU ld & ELF]],
- shared=$enableval, shared=default)
+ shared=$enableval, shared=default)
AC_ARG_ENABLE(profile, dnl
[ --enable-profile build profiled library [default=yes]],
- profile=$enableval, profile=yes)
+ profile=$enableval, profile=yes)
AC_ARG_ENABLE(omitfp, dnl
-[ --enable-omitfp build undebuggable optimized library [default=no]],
- omitfp=$enableval, omitfp=no)
+[ --enable-omitfp build undebuggable optimized library [default=no]],
+ omitfp=$enableval, omitfp=no)
+
+dnl Generic infrastructure for drop-in additions to libc.
+AC_ARG_ENABLE(add-ons, dnl
+[ --enable-add-ons=DIR... configure and build named extra directories],
+ add_ons=`echo "$enableval" | sed 's/,/ /g'`,
+ add_ons=)
+AC_CONFIG_SUBDIRS($add_ons)
AC_CANONICAL_HOST
# We keep the original values in `$config_*' and never modify them, so we