summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>1996-05-08 22:40:39 +0000
committerRoland McGrath <roland@gnu.org>1996-05-08 22:40:39 +0000
commitf0523145cc30a32daa64dd0bd5661b0b204f00da (patch)
tree98b41e707e39b9f8bb37bebbc6602adf16ea4a08 /configure.in
parentc17097f1523ac68c1f65f5bee122dc297ad40455 (diff)
* Makerules (install-lib.so rules): Undouble $s in target and dep
parts of o-iterator-doit defns. (unversioned libraries install rule): Fix pattern. * mach/Makefile (mach-src-headers): Use $(base-machine) instead of $(config-machine). ($(includedir)/machine): Likewise. * config.make.in (base-machine): New variable. * configure.in (machine): Move case stmt to set $machine out of sysdep dirs AC_CACHE_CHECK. (base_machine): New variable, set in that switch and AC_SUBST'd. * Makerules (stub-$(subdir)): Use file name in directory as output, since cmd is cd'd.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in34
1 files changed, 19 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index d8700e6d83..ed288db410 100644
--- a/configure.in
+++ b/configure.in
@@ -95,9 +95,6 @@ alpha*-linux*)
gnu_ld=no elf=no ;;
esac
-# Compute the list of sysdep directories for this configuration.
-sysdep_dir=$srcdir/sysdeps
-AC_CACHE_CHECK(sysdep dirs, libc_cv_sysdirs, [dnl
machine=$config_machine
vendor=$config_vendor
os=$config_os
@@ -107,20 +104,27 @@ changequote(,)dnl
# Expand the configuration machine name into a subdirectory by architecture
# type and particular chip.
case "$machine" in
-a29k | am29000) machine=a29k ;;
-alpha*) machine=alpha/$machine ;;
-hppa*) machine=hppa/$machine ;;
-i[345]86) machine=i386/$machine ;;
-m680?0) machine=m68k/$machine ;;
-m68k) machine=m68k/m68020 ;;
-m88???) machine=m88k/$machine ;;
-m88k) machine=m88k/m88100 ;;
-mips*) machine=mips/$machine ;;
-mips64*) machine=mips/mips64/$machine ;;
-sparc[6789]) machine=sparc/$machine ;;
-supersparc) machine=sparc/sparc8 ;;
+a29k | am29000) base_machine=a29k machine=a29k ;;
+alpha*) base_machine=alpha machine=alpha/$machine ;;
+hppa*) base_machine=hppa machine=hppa/$machine ;;
+i[345]86) base_machine=i386 machine=i386/$machine ;;
+m680?0) base_machine=m68k machine=m68k/$machine ;;
+m68k) base_machine=m68k machine=m68k/m68020 ;;
+m88???) base_machine=m88k machine=m88k/$machine ;;
+m88k) base_machine=m88k machine=m88k/m88100 ;;
+mips*) base_machine=mips machine=mips/$machine ;;
+mips64*) base_machine=mips64 machine=mips/mips64/$machine ;;
+sparc[6789]) base_machine=sparc machine=sparc/$machine ;;
+supersparc) base_machine=sparc machine=sparc/sparc8 ;;
esac
+changequote([,])dnl
+AC_SUBST(base_machine)
+# Compute the list of sysdep directories for this configuration.
+sysdep_dir=$srcdir/sysdeps
+AC_CACHE_CHECK(sysdep dirs, libc_cv_sysdirs, [dnl
+dnl We need to use [ and ] for other purposes for a while now.
+changequote(,)dnl
# Make sco3.2v4 become sco3.2.4 and sunos4.1.1_U1 become sunos4.1.1.U1.
os="`echo $os | sed 's/\([0-9A-Z]\)[v_]\([0-9A-Z]\)/\1.\2/g'`"