summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>1996-03-19 21:23:40 +0000
committerRoland McGrath <roland@gnu.org>1996-03-19 21:23:40 +0000
commitc8cf0b14ed2a085f17c6c5c58ca4a92d97591fcc (patch)
tree62701c5ee52bbfd24a3b1564e6a108c314cf4204 /configure.in
parentc224a18a9045610c4ec1e4d959f6a5dd6b117dd9 (diff)
* configure.in (alpha*-*-linux*): Unset $gnu_ld and $elf.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index d124e49964..6f18093461 100644
--- a/configure.in
+++ b/configure.in
@@ -81,12 +81,18 @@ config_machine=$host_cpu config_vendor=$host_vendor config_os=$host_os
case "$host_os" in
gnu* | linux* | bsd4.4* | netbsd* | freebsd*)
# These systems always use GNU tools.
- gnu_ld=yes gnu_as=yes
+ gnu_ld=yes gnu_as=yes ;;
esac
case "$host_os" in
gnu* | linux* | sysv4* | solaris2*)
# These systems always use the ELF format.
- elf=yes
+ elf=yes ;;
+esac
+
+# Linux/Alpha does not use ELF yet.
+case "$host_cpu-$host_os" in
+alpha*-linux*)
+ gnu_ld=no elf=no ;;
esac
# Compute the list of sysdep directories for this configuration.
@@ -436,7 +442,7 @@ EOF
fi
rm -f conftest*])
-if $libc_cv_asm_weak_directive = no; then
+if test $libc_cv_asm_weak_directive = no; then
AC_CACHE_CHECK(for assembler .weakext directive,
libc_cv_asm_weakext_directive,
[dnl