summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>1996-02-08 02:10:15 +0000
committerRoland McGrath <roland@gnu.org>1996-02-08 02:10:15 +0000
commit4ca84cff3b3e184164acde81deaad1fe52eabd14 (patch)
tree5a3f94f16ef8bd822bee58606b640c1e867aea95 /configure.in
parent1ac3b08e9348daa948d4982f0a4363a6767196e1 (diff)
Wed Feb 7 18:48:30 1996 Roland McGrath <roland@churchy.gnu.ai.mit.edu>
* hurd/hurdmsg.c (_S_msg_report_wait): Function removed. * hurd/report-wait.c: New file. * hurd/Makefile (routines): Added report-wait. * sysdeps/mach/hurd/Makefile (inhibit-unix-syscalls): New variable. * sysdeps/mach/hurd/i386/intr-msg.h (struct mach_msg_trap_args): New type. (SYSCALL_EXAMINE, MSG_EXAMINE): New inline functions. * sysdeps/mach/hurd/i386/trampoline.c (struct mach_msg_trap_args): Structure moved to intr-msg.h; include that. * time/Makefile (CFLAGS-ialloc.c): Add -Wno-unused. (CFLAGS-scheck.c): New variable. * sysdeps/mach/hurd/dl-sysdep.c (__hurd_sigthread_stack_base, __hurd_sigthread_stack_end, __hurd_sigthread_variables, __hurd_threadvar_stack_mask): New variables. * sysdeps/mach/hurd/fork.c: Set the new task's exception port to its new message port. * misc/init-misc.c: Put __init_misc in the __libc_subinit set. * configure.in (uname): Add quoting. * sysdeps/mach/hurd/fchdir.c: Don't consult errno unless lookup fails. * hurd/fchroot.c: Likewise. * posix/sys/types.h [GCC >= 2.7]: Define intN_t/u_intN_t using __attribute__ ((__mode__ (__XX__))). Wed Feb 7 03:24:05 1996 Torbjorn Granlund <tege@tmg.se> * sysdeps/i386/i586/memcopy.h (WORD_COPY_FWD): Manually allocate destination cache lines. (WORD_COPY_BWD): Likewise. Wed Feb 7 14:16:36 1996 Roland McGrath <roland@churchy.gnu.ai.mit.edu> * sysdeps/generic/Makefile (make_siglist): Get signum.h absolute file name first thing, before $(native-compile) changes directories. From Gord Matzigkeit <gord@enci.ucalgary.ca>: * sysdeps/unix/make_errlist.c: Use strerror if available. * sysdeps/unix/configure.in: New file * sysdeps/unix/bsd/sun/syscalls.list: Added sigvec. * sysdeps/unix/bsd/sun/sigvec.S: File removed. * sysdeps/stub/sendto.c: Make sockaddr arg pointer to const. * sysdeps/stub/connect.c: Likewise. * sysdeps/stub/bind.c: Likewise. * hurd/hurdlookup.c (__hurd_file_name_lookup_retry): RETRYNAME of "" is only special for FS_RETRY_NORMAL; for FS_RETRY_REAUTH, do another dir_lookup of "".
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6ad4e5190a..4c9d881100 100644
--- a/configure.in
+++ b/configure.in
@@ -418,13 +418,16 @@ for dir in $sysnames; do
AC_MSG_RESULT(running configure fragment for $dir)
. $sysdep_dir/$dir/configure
fi
+[
if test -z "$uname"; then
if test -r $sysdep_dir/$dir/uname.c ||
test -r $sysdep_dir/$dir/uname.S ||
{ test -r $sysdep_dir/$dir/syscalls.list &&
grep '^uname[ ]' $sysdep_dir/$dir/syscalls.list >/dev/null; }; then
uname=$dir
+ fi
fi
+]dnl
done
AC_LINK_FILES(`echo $libc_link_sources`, `echo $libc_link_dests`)