summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>1995-04-27 05:47:52 +0000
committerRoland McGrath <roland@gnu.org>1995-04-27 05:47:52 +0000
commit10ceac89f949acd0b2e2c32b7c2ad4401a41761d (patch)
treeb7c0d387ec954054c7eb91f93bedf44ecfa3c1ea /configure.in
parent03c5716f9b0e15c87051379c663b56bdabd9c4ce (diff)
Thu Apr 27 01:24:09 1995 Roland McGrath <roland@churchy.gnu.ai.mit.edu>
* configure.in: Unless --without-fp, prepend */fpu before each machine dir in $mach; don't prepend FPU dirs at end. If --with-elf, prepend MACHINE/elf directories at end; don't insert them into $mach. * Makerules (dist): Filter out *.[cSs] from $(distribute) in deps. * sysdeps/stub/clock.c: Added stub warning. * sysdeps/stub/dirfd.c: Likewise. * sysdeps/stub/exc2signal.c: Likewise. * sysdeps/stub/fdopen.c: Likewise. * sysdeps/stub/flock.c: Likewise. * sysdeps/stub/fpathconf.c: Likewise. * sysdeps/stub/ftruncate.c: Likewise. * sysdeps/stub/gtty.c: Likewise. * sysdeps/stub/isatty.c: Likewise. * sysdeps/stub/killpg.c: Likewise. * sysdeps/stub/madvise.c: Likewise. * sysdeps/stub/mkstemp.c: Likewise. * sysdeps/stub/mktemp.c: Likewise. * sysdeps/stub/mprotect.c: Likewise. * sysdeps/stub/msync.c: Likewise. * sysdeps/stub/pathconf.c: Likewise. * sysdeps/stub/poll.c: Likewise. * sysdeps/stub/raise.c: Likewise. * sysdeps/stub/readv.c: Likewise. * sysdeps/stub/setenv.c: Likewise. * sysdeps/stub/setlogin.c: Likewise. * sysdeps/stub/sigaltstack.c: Likewise. * sysdeps/stub/sigintr.c: Likewise. * sysdeps/stub/sigstack.c: Likewise. * sysdeps/stub/sleep.c: Likewise. * sysdeps/stub/sstk.c: Likewise. * sysdeps/stub/stime.c: Likewise. * sysdeps/stub/stty.c: Likewise. * sysdeps/stub/syscall.c: Likewise. * sysdeps/stub/sysconf.c: Likewise. * sysdeps/stub/truncate.c: Likewise. * sysdeps/stub/ualarm.c: Likewise. * sysdeps/stub/usleep.c: Likewise. * sysdeps/stub/utimes.c: Likewise. * sysdeps/stub/writev.c: Likewise. * sysdeps/stub/libc_fatal.c: Remove __NORETURN keyword. Wed Apr 26 16:06:42 1995 Roland McGrath <roland@churchy.gnu.ai.mit.edu> * locale/loadlocale.c (_nl_free_locale): Do nothing if DATA is null. Tue Apr 25 17:17:19 1995 Roland McGrath <roland@churchy.gnu.ai.mit.edu> * posix/glob.c (glob): If GLOB_MARK set, stat names to find directories and append slashes to them in final pass before sorting. (glob_in_dir): If GLOB_MARK set, just allocate the extra char for the slash; never append it here.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in28
1 files changed, 16 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index 11f57c9f9f..bf2e2b1628 100644
--- a/configure.in
+++ b/configure.in
@@ -147,9 +147,9 @@ mach=
tail=$machine
while m=`echo $tail | sed 's@^\(.*\)/\([^/]*\)$@& \1@'`; test -n "$m"; do
set $m
- # If using ELF, look for an `elf' subdirectory of each machine directory.
- if test "$elf" = yes; then
- mach="$mach /$1/elf"
+ # Prepend the machine's FPU directory unless --without-fp.
+ if test "$with_fp" = yes; then
+ mach="$mach /$1/fpu"
fi
mach="$mach /$1"
tail="$2"
@@ -187,21 +187,25 @@ fi
# We have now validated the configuration.
-# Remove the leading slashes.
-sysnames="`echo $sysnames | sed -e 's@^/@@' -e 's@ /@ @g'`"
-
-# Prepend the machine's FPU directory unless --without-fp.
-if test "$with_fp" = yes; then
- fpu_dirs=
+# If using ELF, look for an `elf' subdirectory of each machine directory.
+# We prepend these rather than inserting them whereever the machine appears
+# because things specified by the machine's ELF ABI should override
+# OS-specific things, and should always be the same for any OS on the
+# machine (otherwise what's the point of an ABI?).
+if test "$elf" = yes; then
+ elf_dirs=
for m in $mach; do
- if test -d $sysdep_dir$m/fpu; then
- fpu_dirs="$fpu_dirs $m/fpu"
+ if test -d $sysdep_dir$m/elf; then
+ elf_dirs="$elf_dirs $m/elf"
fi
done
- sysnames="`echo $fpu_dirs | sed -e 's,^/,,' -e 's, /,,g'` $sysnames"
+ sysnames="`echo $elf_dirs | sed -e 's,^/,,' -e 's, /,,g'` $sysnames"
fi
+# Remove the leading slashes.
+sysnames="`echo $sysnames | sed -e 's@^/@@' -e 's@ /@ @g'`"
+
# Expand the list of system names into a full list of directories
# from each element's parent name and Implies file (if present).