summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>1995-04-14 03:52:54 +0000
committerRoland McGrath <roland@gnu.org>1995-04-14 03:52:54 +0000
commite215c4786cff3ecc7961a60f5f79bed50f0fe8c1 (patch)
treefbf34cefb203f9aad43128e555c89ef700c6ea80 /configure.in
parent335aa3209b5d597a93733a7313e629e202731078 (diff)
* Makefile (distribute): Add ChangeLog.[0-9].
* configure.in: Add check for .set directive. * config.h.in: Add #undef HAVE_ASM_SET_DIRECTIVE. * Makerules [! subdir] (O%-lib): Don't prepend ../. * sysdeps/generic/expm1.c: #undef expm1 before weak_alias. See ChangeLog.4 for earlier changes.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index eb5a933f6c..fd9aca4142 100644
--- a/configure.in
+++ b/configure.in
@@ -339,6 +339,25 @@ if test $libc_cv_need_minus_P = yes; then
asm-CPPFLAGS = -P # The assembler can't grok cpp's # line directives."
fi
+AC_MSG_CHECKING(for .set assembler directive)
+AC_CACHE_VAL(libc_cv_asm_set_directive, [dnl
+cat > conftest.s <<\EOF
+.text
+foo: .long 0
+.set bar,foo
+EOF
+if ${CC-cc} $CFLAGS -c conftest.s 2>/dev/null; then
+ libc_cv_asm_set_directive=yes
+else
+ libc_cv_asm_set_directive=no
+fi
+rm -f contest*])
+AC_MSG_RESULT($libc_cv_asm_set_directive)
+if test $libc_cv_asm_set_directive = yes; then
+ AC_DEFINE(HAVE_ASM_SET_DIRECTIVE)
+fi
+
+
# sysdeps configure fragments may set these with files to be linked below.
libc_link_dests=
libc_link_sources=