summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>1995-04-18 20:16:50 +0000
committerRoland McGrath <roland@gnu.org>1995-04-18 20:16:50 +0000
commit65b3cbcba735abd13f10dfdc170ff61411003390 (patch)
treeba356dabf248a58f6a746a788a4edb961d517a26 /configure.in
parent2657da50f0ebedb8c7bf5d51536e842b18e4775a (diff)
Tue Apr 18 14:00:19 1995 Roland McGrath <roland@churchy.gnu.ai.mit.edu>
* configure.in (libc_cv_asm_global_directive): New check to define ASM_GLOBAL_DIRECTIVE. * config.h.in: Add #undef ASM_GLOBAL_DIRECTIVE. * sysdeps/unix/make_errlist.c (main): Don't generate "#ifdef HAVE_WEAK_SYMBOLS" #defns.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 23 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index fd9aca4142..16f5b7b990 100644
--- a/configure.in
+++ b/configure.in
@@ -351,12 +351,34 @@ if ${CC-cc} $CFLAGS -c conftest.s 2>/dev/null; then
else
libc_cv_asm_set_directive=no
fi
-rm -f contest*])
+rm -f conftest*])
AC_MSG_RESULT($libc_cv_asm_set_directive)
if test $libc_cv_asm_set_directive = yes; then
AC_DEFINE(HAVE_ASM_SET_DIRECTIVE)
fi
+AC_MSG_CHECKING(for assembler global-symbol directive)
+AC_CACHE_VAL(libc_cv_asm_global_directive, [dnl
+libc_cv_asm_global_directive=UNKNOWN
+for ac_globl in .globl .global; do
+ cat > conftest.s <<EOF
+.text
+${ac_globl} foo
+foo: .long 0
+EOF
+ if ${CC-cc} $CFLAGS -c conftest.s 2>/dev/null; then
+ libc_cv_asm_global_directive=${ac_globl}
+ fi
+ rm -f conftest*
+ test $libc_cv_asm_global_directive != UNKNOWN && break
+done])
+AC_MSG_RESULT($libc_cv_asm_global_directive)
+if test $libc_cv_asm_global_directive = UNKNOWN; then
+ AC_MSG_ERROR(cannot determine asm global directive)
+else
+ AC_DEFINE_UNQUOTED(ASM_GLOBAL_DIRECTIVE, ${libc_cv_asm_global_directive})
+fi
+
# sysdeps configure fragments may set these with files to be linked below.
libc_link_dests=