summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>1995-03-13 00:37:23 +0000
committerRoland McGrath <roland@gnu.org>1995-03-13 00:37:23 +0000
commit424f8c09fa436a2caa212484d93501cab8eaa39f (patch)
tree1b0b95ded3c76817b446d6173f707352aa9a13e1 /configure.in
parenta2cafe309c31ecc13ca008f1e27a9c7455a95c58 (diff)
Sun Mar 12 18:21:10 1995 Roland McGrath <roland@churchy.gnu.ai.mit.edu>
* malloc/malloc.h (_malloc_internal, _realloc_internal): Declare these. * malloc/realloc.c (_realloc_internal): Renamed from realloc; don't use __realloc_hook. (realloc): New function; call __realloc_hook ?: _realloc_internal. * malloc/malloc.c (_malloc_internal): Renamed from malloc; don't use __malloc_hook. (malloc): New function; call __malloc_hook ?: _malloc_internal. (initialize): Set up _heaplimit to cover the _heapinfo table. (morecore_recursing): New static variable. (morecore): If that is set, return null immediately. When growing the info table, before getting new core from the system for it, set morecore_recursing and try moving _heapinfo with _realloc_internal. When that fails and we get new core, set _heaplimit to cover the core for the new _heapinfo table. (register_heapinfo): New function. Record the _heapinfo table's own blocks in that table and in the statistics variables. (initialize, _malloc_internal): Use it after allocating new table. Fri Mar 10 22:26:28 1995 Jim Meyering (meyering@comco.com) * sysdeps/generic/memchr.c: Remove ansidecl.h and clean up for use by other packages. [LONG_MAX <= LONG_MAX_32_BITS]: Don't compile 64-bit code. * mach/errorlib.h (errors): Use const for decl. * time/tzfile.c (uc2ul, _uc2ul): Macros removed. (decode): New inline function; decode signed 32-bit integers, and sign-extend properly when long is longer than 32 bits. (__tzfile_read): Changed all uses of uc2ul to decode. Decode the transition times properly when sizeof (time_t) > 4. * stdio/vfprintf.c [USE_IN_LIBIO] (PAD): Use return value of _IO_padn. (buffered_vfprintf): Remove line buffer when flush failed.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 28314ca5a4..e6f044bc69 100644
--- a/configure.in
+++ b/configure.in
@@ -41,13 +41,13 @@ dnl Arguments to enable or disable building the shared, profiled, and
dnl -fomit-frame-pointer libraries.
AC_ARG_ENABLE(shared, dnl
[ --enable-shared build shared library [default=yes if GNU ld & ELF]],
- shared=yes, shared=no, shared=default)
+ shared=$enableval, shared=default)
AC_ARG_ENABLE(profile, dnl
[ --enable-profile build profiled library [default=yes]],
- profile=yes, profile=no, profile=yes)
+ profile=$enableval, profile=yes)
AC_ARG_ENABLE(omitfp, dnl
[ --enable-omitfp build undebuggable optimized library [default=no]],
- omitfp=yes, omitfp=no, omitfp=no)
+ omitfp=$enableval, omitfp=no)
AC_CANONICAL_HOST
# We keep the original values in `$config_*' and never modify them, so we