summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJakub Jelinek <jakub@redhat.com>2008-02-01 10:19:38 +0000
committerJakub Jelinek <jakub@redhat.com>2008-02-01 10:19:38 +0000
commit359e8c63c9e6f81802b6ff548a2978f31d79760f (patch)
tree2484b5fbffdfaf382e232df642738d6670db1837 /configure.in
parent7a5a58ec86839aa00f5a16baa1876a5deefcc266 (diff)
Updated to fedora-glibc-20080201T1017cvs/fedora-glibc-2_7_90-6
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 6ea1b26ff3..3098ebfd3d 100644
--- a/configure.in
+++ b/configure.in
@@ -914,8 +914,12 @@ test -n "$aux_missing" && AC_MSG_WARN([
# header directory and add that to the list. NOTE: Only does the right
# thing on a system that doesn't need fixincludes. (Not presently a problem.)
if test -n "$sysheaders"; then
- ccheaders=`$CC -print-file-name=include`
- SYSINCLUDES="-nostdinc -isystem $ccheaders \
+ SYSINCLUDES=-nostdinc
+ for d in include include-fixed; do
+ i=`$CC -print-file-name="$d"` && test "x$i" != x && test "x$i" != "x$d" &&
+ SYSINCLUDES="$SYSINCLUDES -isystem $i"
+ done
+ SYSINCLUDES="$SYSINCLUDES \
-isystem `echo $sysheaders | sed 's/:/ -isystem /g'`"
if test -n "$CXX"; then
cxxversion=`$CXX -dumpversion 2>&AS_MESSAGE_LOG_FD` &&