summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>2000-07-14 16:41:15 +0000
committerUlrich Drepper <drepper@redhat.com>2000-07-14 16:41:15 +0000
commita4301d41219a741ccce13314233d35eee3168316 (patch)
tree2b8f914b7928e2660ec7a61b14f9f79e0cf6f39c /configure.in
parentd45d715a92b76682941444f53683d1c3a857888c (diff)
Check for pwd binary.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 4073ff190e..bf7b307e2e 100644
--- a/configure.in
+++ b/configure.in
@@ -505,6 +505,16 @@ if test "$INSTALL" = "${srcdir}/scripts/install-sh -c"; then
fi
AC_PROG_LN_S
+# We need the physical current working directory. We cannot use the
+# "pwd -P" shell builtin since that's not portable. Instead we try to
+# find a pwd binary. Note that assigning to the PWD environment
+# variable might have some interesting side effects, so we don't do
+# that.
+AC_PATH_PROG(PWD_P, pwd, no)
+if test "$PWD_P" = no; then
+ AC_MSG_ERROR(*** A pwd binary could not be found.)
+fi
+
# These programs are version sensitive.
AC_REQUIRE([AC_CHECK_TOOL_PREFIX])dnl
AC_CHECK_PROG_VER(CC, ${ac_tool_prefix}gcc ${ac_tool_prefix}cc, -v,