summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>2000-05-23 19:23:25 +0000
committerUlrich Drepper <drepper@redhat.com>2000-05-23 19:23:25 +0000
commit2d499f55d78a0265310f5ec931b45172ba39bdb4 (patch)
tree198e63617b7514f68db0e8f2ac34b9cedaca916d /configure.in
parenteec8ef5a73e9a23aa8baedf6b5efc0dc8c077950 (diff)
Update.
* configure.in: Add test for .protected. * config.make.in: Add have-protected variable.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 39bf510d57..14905e6224 100644
--- a/configure.in
+++ b/configure.in
@@ -873,6 +873,21 @@ EOF
AC_DEFINE(HAVE_ASM_POPSECTION_DIRECTIVE)
fi
fi
+ AC_CACHE_CHECK(for .protected and .hidden assembler directive,
+ libc_cv_asm_protected_directive, [dnl
+ cat > conftest.s <<EOF
+.protected foo
+foo:
+.hidden bar
+bar:
+EOF
+ if AC_TRY_COMMAND(${CC-cc} -c $CFLAGS conftest.s 1>&AC_FD_CC); then
+ libc_cv_asm_protected_directive=yes
+ else
+ libc_cv_asm_protected_directive=no
+ fi
+ rm -f conftest*])
+ AC_SUBST(libc_cv_asm_protected_directive)
fi
if test $elf != yes; then