summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>2002-11-24 23:11:14 +0000
committerRoland McGrath <roland@gnu.org>2002-11-24 23:11:14 +0000
commit14519931aee383dd66ddf97bcc8d96c03e4976b4 (patch)
treebccb45329cd24c0256ba24b8de156f61f06aa224 /configure.in
parentd7a5c7e70e50670c050511fa74a6cce335aea15a (diff)
2002-11-24 Roland McGrath <roland@redhat.com>
* configure.in: Skip AUTOCONF check under --without-cvs. * configure: Regenerated.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in30
1 files changed, 16 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index 2804c3f8b1..e8a3dc06a4 100644
--- a/configure.in
+++ b/configure.in
@@ -673,21 +673,23 @@ AC_CHECK_PROG_VER(SED, sed, --version,
[3.0[2-9]*|3.[1-9]*|[4-9]*],
SED=: aux_missing="$aux_missing sed")
-AC_CHECK_PROGS(AUTOCONF, autoconf, no)
-case "x$AUTOCONF" in
-xno|x|x:) AUTOCONF=no ;;
-*)
- AC_CACHE_CHECK(dnl
+if test "x$with_cvs" != xyes; then
+ AC_CHECK_PROGS(AUTOCONF, autoconf, no)
+ case "x$AUTOCONF" in
+ xno|x|x:) AUTOCONF=no ;;
+ *)
+ AC_CACHE_CHECK(dnl
whether $AUTOCONF${ACFLAGS:+ }$ACFLAGS works, libc_cv_autoconf_works, [dnl
- if (cd $srcdir; $AUTOCONF $ACFLAGS configure.in > /dev/null 2>&1); then
- libc_cv_autoconf_works=yes
- else
- libc_cv_autoconf_works=no
- fi])
- test $libc_cv_autoconf_works = yes || AUTOCONF=no
- ;;
-esac
-test "x$AUTOCONF" != xno || aux_missing="$aux_missing autoconf"
+ if (cd $srcdir; $AUTOCONF $ACFLAGS configure.in > /dev/null 2>&1); then
+ libc_cv_autoconf_works=yes
+ else
+ libc_cv_autoconf_works=no
+ fi])
+ test $libc_cv_autoconf_works = yes || AUTOCONF=no
+ ;;
+ esac
+ test "x$AUTOCONF" != xno || aux_missing="$aux_missing autoconf"
+fi
AC_PROG_CC
if test $host != $build; then