summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>2004-04-03 08:53:24 +0000
committerUlrich Drepper <drepper@redhat.com>2004-04-03 08:53:24 +0000
commitfeca5e0be0d18ed2987fe714e1410673d62507db (patch)
tree47c15f90748ccc43159e646f0e22dc066a44e6f7 /configure.in
parent08c9a553c723f301d044062e72871c8d9e6fa510 (diff)
Update.
2004-03-30 H.J. Lu <hongjiu.lu@intel.com> * Makeconfig (link-libc-static): Use $(static-gnulib) instead of $(gnulib). (libgcc_eh): New variable. (gnulib): Use it variable. (static-gnulib): New variable. * Makerules (LDLIBS-c.so): Use $(static-gnulib) instead of $(gnulib). * config.make.in (have-as-needed): New variable. * configure.in: Check if linker supports --as-needed.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 30cf01266c..1f03854534 100644
--- a/configure.in
+++ b/configure.in
@@ -1315,6 +1315,22 @@ EOF
rm -f conftest*])
AC_SUBST(libc_cv_Bgroup)
+ AC_CACHE_CHECK(for --as-needed option,
+ libc_cv_as_needed, [dnl
+ cat > conftest.c <<EOF
+int main (void) { return 0; }
+EOF
+ if AC_TRY_COMMAND([${CC-cc} $CFLAGS $CPPFLAGS $LDFLAGS
+ -shared -o conftest.so conftest.c
+ -Wl,--as-needed -nostdlib 1>&AS_MESSAGE_LOG_FD])
+ then
+ libc_cv_as_needed=yes
+ else
+ libc_cv_as_needed=no
+ fi
+ rm -f conftest*])
+ AC_SUBST(libc_cv_as_needed)
+
ASFLAGS_config=
AC_CACHE_CHECK(whether --noexecstack is desirable for .S files,
libc_cv_as_noexecstack, [dnl