summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>2003-03-27 09:48:09 +0000
committerRoland McGrath <roland@gnu.org>2003-03-27 09:48:09 +0000
commitfd54683c976e506e6311d0fc5d59a7a2d1387d42 (patch)
tree8391a61b59a13f937749f079461eabed7540bcc3 /configure.in
parent130ed2359f57a27949c65d90661ba72306e6c9b7 (diff)
* Makerules (check-abi) [$(enable-check-abi) = warn]:
Ignore exit status from diff. * configure.in (enable_check_abi): Document possible value "warn". Change default to no for now. * configure: Regenerated. * sysdeps/unix/Makefile ($(objpfx)stub-syscalls.c): Emit stub_warning macro calls and a #include <stub-tag.h> at the end. * Makerules ($(objpfx)stubs): Tweak sed commands. * sysdeps/unix/sysv/linux/syscalls.list: Use - rather than EXTRA in caller column for *xattr syscalls, since they are in sysdeps/generic. * sysdeps/unix/sysv/linux/i386/setfsuid.c: setfsgid -> setfsuid * sysdeps/unix/sysv/linux/i386/setfsgid.c: setfsuid -> setfsgid 2003-03-26 Roland McGrath <roland@redhat.com> * Makerules (check-abi-config): Use /thread instead of /tls when use-thread and not just use-tls is set. * Makerules (update-abi): Put quotes around $(update-abi-config). * elf/Makefile (check-abi): Depend on check-abi-ld. (update-abi): Depend on update-abi-ld.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index ee87699123..1795a6a8d6 100644
--- a/configure.in
+++ b/configure.in
@@ -115,10 +115,11 @@ AC_ARG_ENABLE([sanity-checks],
AC_SUBST(enable_check_abi)
AC_ARG_ENABLE([check-abi],
- AC_HELP_STRING([--disable-check-abi],
- [omit "make check-abi" from "make check"]),
+ AC_HELP_STRING([--enable-check-abi],
+ [do "make check-abi" in "make check" (no/warn/yes)
+ @<:@default=no@:>@]),
[enable_check_abi=$enableval],
- [enable_check_abi=yes])
+ [enable_check_abi=no])
dnl Arguments to enable or disable building the static, shared, profiled,
dnl and -fomit-frame-pointer libraries.