summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>2004-01-13 08:36:54 +0000
committerUlrich Drepper <drepper@redhat.com>2004-01-13 08:36:54 +0000
commited20b3d9cc5ce78fd71f32c47b2eb7a897c7a25d (patch)
treec4ea660173f2c8cc138e8f0f1c64055a156c5036 /configure.in
parent1c563add69af03557ba47a4a13790d821133478c (diff)
Update.
2004-01-13 Ulrich Drepper <drepper@redhat.com> * Makeconfig: Define relro-LDFLAGS if have-z-relro==yes. Add it to LDFLAGS.so and LDFLAGS-rtld. (+link): Add relro-LDFLAGS. * Makeconfig (shlib.lds): Place __libc_subfreeres, __libc_atexit, and __libc_thread_subfreeres sections after .jcr section. * config.make.in: Add have-z-relro. * configure.in: Add check for -z relro option. * include/link.h (struct link_map): Add relro_addr and relro_size members. * elf/dl-load.c (_dl_map_object_from_fd): Recognize PT_GNU_RELRO. * elf/dl-reloc.c (_dl_relocate_object): At the end, make relro part of loaded segments read-only. * elf/elf.h: Define PT_GNU_RELRO. * elf/rtld.c (_dl_start): Recognize PT_GNU_RELRO of ld.so. (dl_main): Recognize PT_GNU_RELRO of the application. Call _dl_debug_initialize and initialize l_info[DT_DEBUG] before relocations.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 77e91e30c7..9d2b347e8f 100644
--- a/configure.in
+++ b/configure.in
@@ -1283,6 +1283,16 @@ EOF
rm -f conftest*])
AC_SUBST(libc_cv_z_initfirst)
+ AC_CACHE_CHECK(for -z relro option,
+ libc_cv_z_relro, [dnl
+ if AC_TRY_COMMAND([${CC-cc} -v --help 2>&1|grep "z relro" 1>&AS_MESSAGE_LOG_FD])
+ then
+ libc_cv_z_relro=yes
+ else
+ libc_cv_z_relro=no
+ fi])
+ AC_SUBST(libc_cv_z_relro)
+
AC_CACHE_CHECK(for -Bgroup option,
libc_cv_Bgroup, [dnl
cat > conftest.c <<EOF