summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>2004-03-08 04:10:31 +0000
committerUlrich Drepper <drepper@redhat.com>2004-03-08 04:10:31 +0000
commite2fd3cbe085d9867710ee7b3d487c16c150fa204 (patch)
tree6c145b6019df3a7c10b005c6a10ace5864047331 /configure.in
parent01859b1c24e97f30325a3ce189739e66811c40a4 (diff)
Update.
* config.h.in: Add entry for HAVE_LIBIDN. * configure.in: If libidn add-on present define HAVE_LIBIDN. * Versions.def: Add entry for libcidn. 2004-03-07 Simon Josefsson <jas@extundo.com> * resolv/netdb.h [__USE_GNU]: Add new AI_IDN ai_flags for addrinfo. [__USE_GNU]: Add new error code EAI_IDN_ENCODE for getaddrinfo. * sysdeps/posix/getaddrinfo.c: Add prototype for __idna_to_ascii_lz and define IDNA_SUCCESS. (gaih_inet): If ai_flags have AI_IDN, invoke __idna_to_ascii_lz. (getaddrinfo): Fix EAI_BADFLAGS test to include AI_IDN. All changes only applicable when glibc is compiled with the libidn add-on. 2004-03-07 Ulrich Drepper <drepper@redhat.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ba7fc3d9d9..30cf01266c 100644
--- a/configure.in
+++ b/configure.in
@@ -1903,6 +1903,7 @@ use_ldconfig=no
ldd_rewrite_script=no
libc_cv_sysconfdir=$sysconfdir
libc_cv_gcc_unwind_find_fde=no
+libc_cv_idn=no
# Iterate over all the sysdep directories we will use, running their
# configure fragments, and looking for a uname implementation.
@@ -2045,6 +2046,10 @@ if test $shared = default; then
fi
fi
+if test x"$libc_cv_idn" = xyes; then
+ AC_DEFINE(HAVE_LIBIDN)
+fi
+
AC_CACHE_CHECK([whether -fPIC is default], pic_default,
[pic_default=yes
cat > conftest.c <<EOF