summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>2004-08-05 03:34:45 +0000
committerRoland McGrath <roland@gnu.org>2004-08-05 03:34:45 +0000
commit9382fcee61189ac51a96b29cad75348737f0b47f (patch)
treeb9bfc24233d25bd7c991bf5c5770ff8cc5620bfb /configure.in
parent8cc5920e23990aaef097343fc1003092fff98abd (diff)
* Makeconfig ($(common-objpfx)config.status):
Fix typo: $(add_ons) -> $(add-ons). (Makeconfig-add-on): New variable. When doing $(sysdep-makeconfigs) include, use black magic to get it set to an add-on's name during the include of the add-on's Makeconfig. * configure.in: Use variable name `libc_add_on' when sourcing add-on configure fragments, so they can refer to this. * configure: Regenerated.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 2391313de8..89344bf0ec 100644
--- a/configure.in
+++ b/configure.in
@@ -362,13 +362,15 @@ if test x"$add_ons" != x; then
fi
done
- for f in $add_ons; do
- frag=$srcdir/$f/configure
- if test -r $frag; then
- AC_MSG_RESULT(running configure fragment for add-on $f)
- . $frag
+ # Now source each add-on's configure fragment.
+ # The fragments can use $srcdir/$libc_add_on to find themselves.
+ for libc_add_on in $add_ons; do
+ libc_add_on_frag=$srcdir/$libc_add_on/configure
+ if test -r $libc_add_on_frag; then
+ AC_MSG_RESULT(running configure fragment for add-on $libc_add_on)
+ . $libc_add_on_frag
else
- AC_MSG_WARN(add-on fragment $frag missing)
+ AC_MSG_WARN(add-on fragment $libc_add_on_frag missing)
fi
done
fi