summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>2003-03-26 01:15:07 +0000
committerRoland McGrath <roland@gnu.org>2003-03-26 01:15:07 +0000
commit7dbde9db6b8cb8e77358dcb9fd883ded874858c9 (patch)
treee657e20c8b03cef543d69cdf9d9c46808d6db8cd /configure.in
parent9fdf211e6866677d67167ba7a77ac4798fe5cb1d (diff)
2003-03-25 Roland McGrath <roland@redhat.com>
* config.make.in (enable-check-abi): New variable from configure. * configure.in (enable_check_abi): New substituted variable, controlled by --{enable,disable}-check-abi (default yes). * configure: Regenerated. * Makerules [$(enable-check-abi) = yes] (tests): Put this condition on check-abi dependency.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f5d399b25f..ee87699123 100644
--- a/configure.in
+++ b/configure.in
@@ -113,6 +113,13 @@ AC_ARG_ENABLE([sanity-checks],
[enable_sanity=$enableval],
[enable_sanity=yes])
+AC_SUBST(enable_check_abi)
+AC_ARG_ENABLE([check-abi],
+ AC_HELP_STRING([--disable-check-abi],
+ [omit "make check-abi" from "make check"]),
+ [enable_check_abi=$enableval],
+ [enable_check_abi=yes])
+
dnl Arguments to enable or disable building the static, shared, profiled,
dnl and -fomit-frame-pointer libraries.
dnl I've disabled this for now since we cannot build glibc without static