summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>2002-10-01 08:45:44 +0000
committerRoland McGrath <roland@gnu.org>2002-10-01 08:45:44 +0000
commit749a9a4fbfd261e2d9811d9bc4507478c2f7cc58 (patch)
tree17cafa03770236ee2f1b6671f22501b35eaf816d /configure.in
parentd1f69fed96fdb47aa7394d6e0ece1e16811d55fd (diff)
2002-10-01 Roland McGrath <roland@frob.com>
* config.h.in (NO_HIDDEN): New #undef. * include/libc-symbols.h [! NO_HIDDEN]: Add this condition to nonempty definitions of hidden_proto et al. * configure.in: Grok --disable-hidden-plt to define NO_HIDDEN. * configure: Regenerated. * sysdeps/mach/hurd/configure.in: Always define NO_HIDDEN. * sysdeps/mach/hurd/configure: Regenerated.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d3d713148b..12a6a0f56d 100644
--- a/configure.in
+++ b/configure.in
@@ -145,6 +145,13 @@ AC_ARG_WITH(tls, dnl
[ --with-tls enable support for TLS],
usetls=$withval, usetls=no)
+AC_ARG_ENABLE(hidden-plt, dnl
+[ --disable-hidden-plt do not hide internal function calls to avoid PLT],
+ hidden=$enableval, hidden=yes)
+if test "x$hidden" = xno; then
+ AC_DEFINE(NO_HIDDEN)
+fi
+
AC_CONFIG_SUBDIRS($add_ons)
add_ons_pfx=
if test x"$add_ons" != x; then