summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>2003-04-01 06:50:04 +0000
committerRoland McGrath <roland@gnu.org>2003-04-01 06:50:04 +0000
commit640f0119273fde93038261e493fdda96e7dd7e11 (patch)
treef54f82169f00071fb117ace9f9a5b0a130479948 /configure.in
parent22f974f6c0c2219c06cb2f2eebf2785679ec6960 (diff)
* configure.in: Don't require an installed C library in the test
for ".set" assembler support. * configure: Regenerated. 2003-03-31 Roland McGrath <roland@redhat.com> * signal/tst-sigset.c: New file. * signal/Makefile (tests): Add it.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 9a08b6c32c..f48a9e8f10 100644
--- a/configure.in
+++ b/configure.in
@@ -977,9 +977,10 @@ EOF
# (but it doesn't work), so we must do a linking check to be sure.
cat > conftest1.c <<\EOF
extern int glibc_conftest_frobozz;
-main () { printf ("%d\n", glibc_conftest_frobozz); }
+void _start() { glibc_conftest_frobozz = 1; }
EOF
if ${CC-cc} $CFLAGS $CPPFLAGS $LDFLAGS \
+ -nostartfiles -nostdlib \
-o conftest conftest.s conftest1.c 1>&AS_MESSAGE_LOG_FD 2>&AS_MESSAGE_LOG_FD; then
libc_cv_asm_set_directive=yes
else