summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>2003-04-30 04:17:59 +0000
committerRoland McGrath <roland@gnu.org>2003-04-30 04:17:59 +0000
commit476e7d78f4db291606903b9616515d47598dc791 (patch)
tree3b4094e94a7dd7d965660a4b9de7db56dc4ecfe8 /configure.in
parent153da5995c2d820a221aa5388edf2fb229ed3450 (diff)
2003-04-29 Roland McGrath <roland@redhat.com>
* configure.in: Search for AUTOCONF unconditionally. Just don't complain about missing it under --without-cvs. * configure: Regenerated.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 16 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index 1a21191940..f0511ac5f9 100644
--- a/configure.in
+++ b/configure.in
@@ -721,22 +721,23 @@ AC_CHECK_PROG_VER(SED, sed, --version,
[3.0[2-9]*|3.[1-9]*|[4-9]*],
SED=: aux_missing="$aux_missing sed")
-if test "x$with_cvs" != xyes; then
- AC_CHECK_PROGS(AUTOCONF, autoconf, no)
- case "x$AUTOCONF" in
- xno|x|x:) AUTOCONF=no ;;
- *)
- AC_CACHE_CHECK(dnl
+AC_CHECK_PROGS(AUTOCONF, autoconf, no)
+case "x$AUTOCONF" in
+xno|x|x:) AUTOCONF=no ;;
+*)
+ AC_CACHE_CHECK(dnl
whether $AUTOCONF${ACFLAGS:+ }$ACFLAGS works, libc_cv_autoconf_works, [dnl
- if (cd $srcdir; $AUTOCONF $ACFLAGS configure.in > /dev/null 2>&1); then
- libc_cv_autoconf_works=yes
- else
- libc_cv_autoconf_works=no
- fi])
- test $libc_cv_autoconf_works = yes || AUTOCONF=no
- ;;
- esac
- test "x$AUTOCONF" != xno || aux_missing="$aux_missing autoconf"
+ if (cd $srcdir; $AUTOCONF $ACFLAGS configure.in > /dev/null 2>&1); then
+ libc_cv_autoconf_works=yes
+ else
+ libc_cv_autoconf_works=no
+ fi])
+ test $libc_cv_autoconf_works = yes || AUTOCONF=no
+ ;;
+esac
+if test "x$with_cvs" = xyes && test "x$AUTOCONF" = xno; then
+ # If --without-cvs they probably won't change configure.in, so no complaints.
+ aux_missing="$aux_missing autoconf"
fi
test -n "$critic_missing" && AC_MSG_ERROR([