summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>2003-04-02 20:03:30 +0000
committerRoland McGrath <roland@gnu.org>2003-04-02 20:03:30 +0000
commit426074293fbc1c90585b2864416ff506cdf7eda5 (patch)
tree9d6f8f58e86ab971f0c50d237fb436c6f50e3461 /configure.in
parentfabb2e1c04a9ec95ddeb4a506e5f3deda01202fe (diff)
* configure.in: Check for __register_frame_info in both
-lgcc and -lgcc_eh. * configure: Regenerated.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 6 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index 083929cc38..f71f984439 100644
--- a/configure.in
+++ b/configure.in
@@ -1604,19 +1604,13 @@ abort () {}
__bzero () {}
dl_iterate_phdr () {}
EOF
-dnl No \ in command here because it ends up inside ''.
-if AC_TRY_COMMAND([${CC-cc} $CFLAGS -DCHECK__register_frame_info
- -nostdlib -nostartfiles
- -o conftest conftest.c -lgcc >&AS_MESSAGE_LOG_FD]); then
- libc_cv_gcc_dwarf2_unwind_info=static
-else
- libc_cv_gcc_dwarf2_unwind_info=no
-fi
-# Some platforms' specs put -lgcc first. The second one doesn't hurt.
libc_unwind_check="${CC-cc} $CFLAGS -DCHECK__register_frame_info \
- -nostdlib -nostartfiles -o conftest conftest.c \
- -lgcc -lgcc_eh -lgcc"
-if AC_TRY_COMMAND([$libc_unwind_check >&AS_MESSAGE_LOG_FD]); then
+ -nostdlib -nostartfiles -o conftest conftest.c \
+ -lgcc"
+# Some platforms' specs put -lgcc first. The second one doesn't hurt.
+if AC_TRY_COMMAND([$libc_unwind_check >&AS_MESSAGE_LOG_FD]) ||
+ AC_TRY_COMMAND([$libc_unwind_check -lgcc_eh -lgcc >&AS_MESSAGE_LOG_FD])
+then
if $libc_unwind_check -v 2>&1 >/dev/null \
| grep -q -- --eh-frame-hdr; then
libc_cv_gcc_dwarf2_unwind_info=no_registry_needed