summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>2004-09-16 23:22:05 +0000
committerRoland McGrath <roland@gnu.org>2004-09-16 23:22:05 +0000
commit3d6ce23a90fea094d77b5e2f5574d10e5ecb9d61 (patch)
tree5aa78e2b87006d6bf7083696ee3091eb62a1212a /configure.in
parent62417d7ee84a198103fbc5e871bf35e0d5efc4d0 (diff)
2004-09-16 Roland McGrath <roland@redhat.com>
* configure.in (--with-headers): Let argument contain a : separated list of directories to use, not just one. * configure: Regenerated.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 665786e182..22f726e3bb 100644
--- a/configure.in
+++ b/configure.in
@@ -799,7 +799,8 @@ test -n "$aux_missing" && AC_MSG_WARN([
# thing on a system that doesn't need fixincludes. (Not presently a problem.)
if test -n "$sysheaders"; then
ccheaders=`$CC -print-file-name=include`
- SYSINCLUDES="-nostdinc -isystem $ccheaders -isystem $sysheaders"
+ SYSINCLUDES="-nostdinc -isystem $ccheaders \
+-isystem `echo $sysheaders | sed 's/:/ -isystem /g'`"
fi
AC_SUBST(SYSINCLUDES)